
1 Introduction

MyDraw is a powerful, yet easy to use diagram software. It provides a large selection of shapes, formula based engine
like in Microsoft Visio, a lot of automatic layout algorithms and many other features. The following list outlines the
main features of MyDraw in more details:

UI
Library browser
Pan and zoom view
Drawing view with different view modes
Rulers
Guidelines
Predefined UI themes:

Windows 10
Windows 8
Windows 7 Aero
Windows XP
Mac OS El Capitan
Mac OS Lion
Nevron Light
Several windows classic themes

A "New Drawing" dialog with a large set of drawing templates to choose from
Document

Multiple pages
Large number of predefined shapes
Grouping and ungrouping of shapes
1D and 2D barcodes
Measurement units and scaling
Formulas

Interaction
Rotation, scaling and moving of shapes and groups
Many tools such as pointer tool, rectangle tool, ellipse tool, geometry tool, pan tool, etc.
Snap and glue
Spacing and positioning of shapes
Automatic layouts and routing
Shape protections
In place editing and formatting of texts
Tooltips and clickable hyperlinks for shapes and groups

Printing
Print dialog with settings for page size, margins and layout mode
Ability to exclude certain shapes and groups from printing

Formats
Native MyDraw XML and binary based formats
Native MyDraw XML template format
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Visio Drawing (VSDX, VSD) and stencil (VSSX, VSS) import and export
Import of map data from ESRI shapefiles (SHP)
Import and export of genealogical data in GEDCOM format (GED), for example: family trees
Raster image export: bitmap (BMP), JPEG, PNG
Vector image export: SVG, EMF
PDF export
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2 Licensing
Online Activation
Activate MyDraw Product Licenses

If you have purchased a license for MyDraw, you can activate it as follows:

1. Launch MyDraw and create a new blank drawing
2. Click the File menu and then About
3. Click the Log into MyDraw Account...   
4. Enter the username (e-mail) and password of your MyDraw account
5. Click the Log in button to login into your account.
6. Click the Activate with MyDraw Account to activate the software.
7. Restart MyDraw for changes to take effect.

Revoke or Transfer MyDraw Licenses

At any time you can transfer you license to another computer by deactivating it first on your current computer and
then activating the license on the new computer following the above procedure. To deactivate your license on your
current computer, do the following:

1. Launch MyDraw and create a new blank drawing
2. Click the File menu and then About
3. Click the Log into MyDraw Account...
4. Enter the username (e-mail) and password of your MyDraw account.
5. Click the Deactivate from MyDraw Account button to deactivate the software
6. Restart MyDraw for changes to take effect

After deactivating a license on one computer, you will be able to activate it on another computer.

Local Activation
If the computer you have installed MyDraw on doesn't have an Internet connection, you can activate MyDraw locally
by doing the following:

1. Obtain your unique machine id from the watermark displayed on your blank drawing.
2. Send the machine id to sales@mydraw.com and we'll respond with a license key. 
3. Click the File menu in MyDraw's ribbon and then click About.
4. Click the Activate with license key button
5. Enter the license key issued for your machine id and press Activate.

After you receive a registration code click the File menu in MyDraw's ribbon and then click About and in the dialog
that opens, perform these steps:

1. Click the Activate with license key button.
2. Enter the license key issued for your machine id and press Activate.

That's it, you have successfully applied the license key to MyDraw.
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3 Version History

Version 5.0.0 (November 2020)

Windows 10 theme.
Redesigned library browser.
300+ new libraries.
Thousands of new shapes.
Shape hyperlinks.
20% faster startup of MyDraw.
AutoCAD import and export improvements.
Visio import and export improvements.
Turkish language translation of the UI.

Version 4.3.0 (January 2020)

AutoCAD Drawing Interchange (DXF) import.
Visio import and export improvements.
UI improvements and bug fixes.

Version 4.2.0 (November 2019)

New drawing templates: Invoices, Scorecards, Scientific and Mind Maps.
Unit selection dialog when opening a template.
Visio import and export improvements.
Enhanced Metafile (EMF) image support improvements.
Ribbon interface and other UI improvements.
Improved table shapes.

Version 4.1.2 (October 2019)

UI improvements and bug fixes.

Version 4.1.1 (September 2019)

Performance and stability improvements.

Version 4.1.0 (August 2019)

UI improvements and bug fixes.
Improved Mac printing.

Version 4.0.0 (July 2019)

Diagram improvements:
Support for shape shadows.

Visio import and export improvements:
Support for shape shadow import and export.

MyDraw User Guide 7

©2020 Nevron Software. All Rights Reserved.



Export of tables as grouped shapes in Visio.
Various bug fixes and small improvements.

UI improvements:
Quick access toolbar added to the ribbon with option to customize the items in the toolbar.
The palette color picker in color dialogs replaced with a more user friendly hexagon color picker.
Color pickers across the UI replaced with theme color pickers, so that changing the theme of the page
can affect the coloring of the shapes.
Sidebar added at the right side of MyDraw window to allow users quickly style shapes.
Improved image export dialogs – they now include a preview of the exported drawing page and let the
user select an area of the page to export both by entering its exact size or by dragging and dropping
the export bounds borders.

Localization improvements:
Improved UI translations.
Localization dictionaries now include a setting for the desired font size and for the Chinese and
Japanese languages a larger font is used to make them more readable.

Mac specific improvements:
Support for multiple MyDraw windows – users can now right click MyDraw‘s icon in the dock and open
a new window. This will allow them to have multiple drawings open at the same time with an option to
drag and drop, copy and paste shapes between MyDraw windows.
List of recent documents added to MyDraw‘s start screen and „File“ menu.

Version 3.9.0 (February 2019)

Import Flowchart from Excel sheet.
Import Organizational diagram from Excel sheet.
Visio import and export improvements.
New shapes and drawing templates.
UI improvements and bug fixes.

Version 3.0.0 (September 2018)

Drawing themes and shape styles
Import of vector images in Windows Metafile (WMF) and Enhanced Metafile (EMF) format
Visio import and export improvements
Family shapes in family tree diagrams are now filled differently based on the family status: not married (green),
married (blue) and divorced (red)
A lot of new shape libraries and drawing templates
UI improvements and bug fixes
Support for tables

Row and column master cells, cell merge and split
Text orientation - horizontal, vertical
Per cell fill and border
Collapsed and expanded cells margins support
Row and column resizing
Table columns with percentage, fixed and automatic width
In place editing of tables
Automatic ports generation (table cell, grid, column or rows only)
Collapsible Borders
Different table resize modes
Auto table sizing
Find and replace text in tables
Multi-range selection of table cells, rows and columns.
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Version 2.3.1 (May 2018)

Visio export improvements
UI improvements and bug fixes

Version 2.3.0 (May 2018)

All non-native file formats moved to Import and Export menu items
Visio import and export improvements
Import of flowcharts from Excel data
UI improvements and bug fixes

Version 2.2.0 (April 2018)

Bookmarks of drawing view position and zoom level
Presentation mode
Check for updates and auto update
Tagged Image File Format (TIFF)

Version 2.1.1 (March 2018)

Bug fixes and stability improvements

Version 2.1.0 (March 2018)

Improved print preview and printing
Support for connector splitting when dropping a 2D shape on a connector
Drawing documents now store which libraries were opened when they were last saved
Visio export improvements
Added German translation of the user interface

Version 2.0.3 (February 2018)

Contextual help in property editors
Improved support for high resolution displays (WQHD, 4K Ultra HD, etc.)
Improved support for multi-monitor environments

Version 2.0.2 (January 2018)

Support for Windows XP (.NET Framework 3.5 should be installed)
Visio import improvements
UI improvements and bug fixes

Version 2.0.1 (December 2017)

Mini toolbar added to context menu
Bug fixes

Version 2.0.0 (November 2017)
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New file formats:
AutoCAD (DXF) export
Visio 2003-2010 Drawings (VSD, VDX)
Visio Stencils (VSSX)
Visio 2003-2010 Stencils (VSS, VSX)
Enhanced Metafiles (EMF)

New shape libraries
New drawing templates
Autosave
Multi-monitor support
UI improvements and bug fixes

Version 1.0.1 (June 2017)

UI, stability and performance improvements
Bug fixes

Version 1.0.0 (May 2017)

First version of MyDraw
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4 User Interface

4.1 Templates and New Drawings
The New Drawing dialog is shown when you start MyDraw. You can open recent documents, create a blank
drawing, or create a drawing based on a template. 

 

The dialog consists of two main parts:

Main Content
The main content of the New Drawing dialog lets you create a blank new drawing or create a drawing based on a
template and consists of the following widgets:

Template Search Box: lets you search for a drawing template by name. Simply start typing in the search box
and you will see a list of matching templates. To open any the templates in the list, click it with the left mouse
button or select it with the arrow keys and press Enter.
Breadcrumb: lets you go back to a parent category in the list of templates.
Template Picker: lets you select a drawing template to open in MyDraw. At the root level of the template
selector you can also select the "Blank Drawing" option to create a blank new drawing or the "New from
Existing..." option to create a new drawing based on an exsiting one. The other items in the template picker are
template categores. If you click any of them, the category will open and you will see its templates and sub
categories.

Sidebar
The sidebar is placed at the left side of the New Drawing dialog and lets you open one of the recently opened
drawings. You can pin/unpin and remove drawings from the recent documents list. Below the list of recent documents
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you will find an Open button that lets you browse to a drawing of your choice and open it in MyDraw.

4.2 Ribbon
The ribbon contains a set of buttons, menus, combo boxes and other command controls organized logically in groups
and tabs that allows you manipulate the diagram, add, arrange and style shapes, and access nearly all controls of
MyDraw. Each text tab at the top of the ribbon opens up a different set of clickable commands.

Each command item in the ribbon has a tooltip, which contains information about the command and its
keyboard shortcut (if any), so when in doubt about what a given command does, simply move the mouse
pointer over it and wait a second for the tooltip to show up.

Home Tab Page
The Home tab page is the default page of the diagram ribbon.

As the image above shows the Home tab page is organized into the following ribbon groups:

Clipboard: lets you cut or copy the currently selected shapes. When there are compatible objects in the
clipboard you can also use the Paste button to paste them in your diagram.
Font - lets you control the font, size and appearance of the text of the currently selected shape.
Paragraph - lets you specify the text alignment of the currently selected shape.
Geometry Format - lets you control the fill, stroke, shadow and corner rounding of the currently selected
shape. For 1D shape (i.e. connectors) you can also specify the begin and end arrowhead styles.
Tools - contains a set of tools that you can activate in order to create custom shapes, edit the geometry of a
shape, insert text, pan the diagram or simply to go back to the default tool as shown on the above image - the
pointer tool.
Editing - lets you undo/redo the recently made changes to your diagram, as well as to select all shapes, all 1D
shapes or all 2D shapes.
Search - contains buttons for finding and replacing texts in shapes

Design Tab Page
The Design tab page lets you quickly configure the theme of the active page and the style of individual shapes.

The Design tab page consists of the following ribbon groups:

Page - lets you configure the orientation and the size of the active page.
Shape Style - lets you quickly style a shape using a shape style from the currently selected page theme and
variant.
Page Theme - lets you quickly change the look of all shapes in a page by changing the theme of the page.
Page Theme Variant - can be used to apply a variant of the currently selected theme to the active page.

For more information about the drawing themes and shape styles, check out the Themes and Styles documentation
topic.
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Action Tab Page
The Action tab page lets you manipulate the currently selected shape/shapes.

The Action tab page consists of the following ribbon groups:

Group - lets you group and ungroup a set of shapes.
Rotate - lets you flip or rotate a shape.
Compose - lets you create a complex geometry shape by performing a geometry operation to a set of shapes.

Arrange Tab Page
The Arrange tab page lets you position, size and align your shapes:

The Arrange tab page consists of the following ribbon groups:

Align - lets you align two or more shapes.
Resize - lets you size one or more shapes to another shape.
Position - lets you position a shape within the page.
Z-order - lets you bring a shape above or below other shapes.
Spacing - lets you configure the spacing between two or more shapes.
Grid - lets you align or size shapes to grid.
Snap - lets you configure the snapping behavior of MyDraw.
Layout - contains a Layout Shapes button, which when clicked opens a dialog for selecting, configuring and
applying an automatic layout to the selected or all shapes of your diagram.

Insert Tab Page
The Insert tab page lets you insert an object into the document.

The Insert tab page currently has the following ribbon groups:

Illustrations - lets you easily insert an image or a 1D/2D barcode to your diagram. If you insert a barcode, you
can then right click it to modify its properties.
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Symbols - lets you insert special text characters and symbols into the text block of a shape
Text - lets you insert hyperlinks and different text fields into the text block of a shape

Review Tab Page
The Review tab page lets you perform a spell check of the texts of a drawing.

The Review tab page currently has the following ribbon buttons:

Spell Check - a toggle button that enables or disables the spell checking for the whole document.
Symbols - lets you select the spell check dictionary to use. You can use any of the included spell check
dictionaries or load a different spell check dictionary using the Browse button. MyDraw is compatible with
Open Office spell check dictionaries.

Mailings Tab Page
The Mailings tab page lets you configure and perform a mail merge operation.

For more information, check out the Mail Merge topic.

View Tab Page
The View tab page lets you control the visibility, the behavior and the settings of various elements of the drawing
view.

For more information, check out the Drawing View topic.

Application Menu
The application menu is shown when you click on File. It contains menu items for saving the diagram or loading a
diagram from a file, for printing and export and so on. It also contains the menu item for showing the About dialog
and the button that shows the Options dialog, which you can use to switch the current UI theme, or switch to
traditional command bar UI. It also lets you switch the user interface to another language. The application menu also
contains a New menu option that opens the New Drawing Dialog.
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The right side of the application menu shows the recently opened/saved documents with the ability to pin the ones
you find more important.

4.3 Quick Access Toolbar
The custom toolbar is an area where you can place your most frequently used commands and menu buttons.

To add icons to the custom toolbar, first click on the down arrow, and then “Customize” in the drop down menu.

Then, click on the command you wish to add to the Quick Access Toolbar, and click the add button in the center of
the box.  The command will shift to the right side of the box, signifying that it will be shown on the toolbar. As the bar
is horizontal, the topmost icon will be shown the furthest left on the toolbar. To change the order of the command
icons, move them up and down in list order by highlighting the icon you wish to move, and clicking on the up or
down arrows on the right side of the box.

You may check your toolbars layout before committing it at the bottom of the box in the “Toolbar Preview” pane. To
accept all changes, click OK.

4.4 Library Browser
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Library Browser Overview
The library browser is a visual component that helps you use, manage and create libraries of shapes. It is organized as a vertically arranged
collection of sections. The following picture illustrates the main elements of the library browser:

 

fig. 1 - Library Browser Elements

There are two types of sections that can reside in the library browser:

1. Library Section - this type section is associated with a single library of shapes that you open either from a file on your system, or from the
set of predefined libraries that come along with MyDraw. In fig. 1 the Basis Shapes, Connector Shapes and Arrow Shapes are library
sections. You can drag and drop shapes from expanded library section onto the drawing - in our case from the Arrow Shapes library
section. 

2. Search Section - this type section is created from each search that you perform from the search bar (see Searching for Shapes below). You
can drag and drop shapes from search sections onto the drawing and also open the libraries in which these shapes are found in separate
library sections.

Library Commands Menu and Context Menu
When clicked Library Commands Menu Button shows the following menu, the commands of which are explained below:
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fig. 2 - Library Commands Menu

General Commands

Library Gallery... - opens the Library Gallery Dialog. From this dialog you can browse and open a large amount of shape libraries that
come along with MyDraw.
New Library... - creates a new library and opens it in the library browser. You can add shapes to this new library, by dragging and dropping
shapes from the drawing view to the library.
Open Library... - shows the Select File Dialog, that lets you select a library file to be opened in the library browser. You can open libraries
in MyDraw (.nlx, .nlb) or Visio (.vssx) format.
Save Library - saves the expanded library to the file from which it was originally opened.
Save Library As... - saves the expanded library to the file that you select from the Select File Dialog.
Close - closes the currently expanded section.
Close All - closes all sections of the library browser.

View Type Commands

Icons View Type - switches the view type of all sections to Icons.
List View Type - switches the view type of all sections to List.
Thumbnails View Type - switches the view type of all sections to List.

the following table demonstrates the different view types:
Icons List Thumbnails

Display Order Commands

Default Display Order - switches the order of all sections to Default.
Text Ascending Display Order - switches the order of all sections to Text Ascending (A to Z order).
Text Descending Display Order - switches the order of all sections to Text Descending (Z to A order). 

When you right click on a Library Section, MyDraw will open the following context menu, the commands of which are explained below:
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Save - save the library to the file from which it was opened.
Saves As... - saves the library to the file that you select from the Select File Dialog.
Move Up - moves the library section up in the Library Browser.
Move Down - moves the library section down in the Library Browser.
Library Properties - shows the Library Properties Dialog from which you can edit the library title, author etc.

Library Gallery Dialog
The Library Gallery Dialog is opened from the Library Gallery... command, which is the first command inside the Library Commands Menu. It
helps you browse through the set of libraries that come installed with MyDraw and open them inside the Library Browser. The following image
illustrates the library gallery and its elements:

fig 3. Library Gallery Dialog 

On the left side you can see two tabs:

1. Libraries Tab - from this tab you can browse the shape libraries that come installed with MyDraw. The libraries are organized in categories,
like Clipart, General, Business etc. Libraries, whose check is checked will be opened in the Library Browser, when the Library Gallery
Dialog is closed. The selected library inside this tab is previewed inside the Selected Library Preview located on the right side of the
dialog.

2. Search Tab - from this tab you can search for shapes and shape libraries, which is explained below.

Searching for Shapes
There are two ways in which you can search for shapes - from the Search Box in the Library Browser and from the Search Tab in the Library
Gallery

1. Searching via the Search Box in the Library Browser
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fig. 4 Searching using the Search Box.

The Search Box helps you search for shapes inside the Opened Libraries inside the Library Browser and/or the libraries from the Library
Gallery. To perform the search you need to:

1. Type the text you want to search for inside the Search Box - in fig. 4 this string is dog.

2. Click on the Search Button. The results of the search will be opened in a new section - in fig. 4 this is the Search results for "dog"
section.

The options of the search are controlled by the controls inside the Search Options Menu, which is shown when you click on the Show
Search Options Menu button. The options for the search are:

Case Sensitive - whether the search should distinguish between lower and upper letters.
Search in Opened Libraries - when checked, the search will look for shapes inside the libraries that are opened in the Library
Browser.
Search in Library Gallery - when checked, the search will look for shapes inside all libraries that are available in the Library Browser.
Match Mode - specifies the mode in which the string matching is performed (see below).

The libraries, which contain shapes that match the search criteria are opened in collapsible groups - in fig. 4 these are Animals, Animals and
Nature, Circus etc. Only the shapes that match are shown inside these libraries. You can drag and drop the matching shapes on the drawing
view. You can also open the library that contains the matching shapes in a separate library section by clicking on the Open Library in New
Section button. Initially the search will shown only the first 5 libraries that contain matching shapes, you can show the next 5 by clicking on
the Show More Libraries button, which is automatically disabled when there are no more libraries to be shown.

12. Searching via the Search Tab in the Library Gallery
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fig. 5 - Searching using the Search Tab                     

The Search Tab helps you search for shapes, libraries and folders inside the Library Gallery. To perform the search you need to:

1. Type the text you want to search for inside the Search Box - in fig. 5 this string is dog.

2. Click on the Search Button. The results of the search will be displayed as a tree-view in the search tab.

The options of the search are controlled by the controls inside the Search Options Menu, which is shown when you click on the Show
Search Options Menu button. The options for the search are:

Case Sensitive - whether the search should distinguish between lower and upper letters.
Search for Shapes - when checked, the search will look for shapes inside the libraries that are available in the Library Browser.
Search for Libraries - when checked, the search will look for libraries, whose names match.
Search for Folders - when checked, the search will look for folders, whose names match.
Match Mode - specifies the mode in which the string matching is performed (see below).

- Match Mode - this search option controls the conditions under which a certain text string matches the characters that you entered. The
following match modes are available:

Contains: matches when the string contains the entered characters
Starts with: matches when the string starts with the entered characters
Word Starts with: matches when the string contains a word that starts with the entered characters
Ends with: matches when the string ends with the entered characters
Word Ends with: matches when the string contains a word that ends with the entered characters
Contains Any Word: matches when the string contains a word starting with one of the words of a given substring and orders the matched
shapes by the number of matched words
Contains All Words: matches when the string contains all of the entered words
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4.5 Drawing View
The drawing view is the main center pane of MyDraw. This is the area where the project you are currently working on
is shown, and where you will manipulate shapes, colors, text, etc. There are optional rulers on the top and left side of
the drawing area, and a status bar at the bottom, with the ability to add additional pages to the current project. The
drawing area can be right-clicked for a context menu at any time.

 To help you position shapes more precisely it shows a grid and rulers by default. The view also aids you by providing
snapping behavior to grids, rulers and guidelines.

Guidelines are vertical or horizontal lines you can use to align shapes to. To create a guideline simply drag the
horizontal or the vertical ruler towards the drawing view. If you want to center the guideline in the page, right click it
and select Center in Page.

You can show and hide different elements of the drawing view as well as to control its zooming mode through the
View tab page of MyDraw's ribbon:

Show Ribbon Group
The Show ribbon group toggles the visibility of the different elements such as grid, guidelines, ports, rulers, etc. The
following image illustrates the elements you can show or hide using the check boxes of the Show ribbon group:
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You can use the Splitter collapse buttons to collapse and expand the splitter pane and the library. MyDraw saves these
settings, so the splitter positions you set will be applied again the next time you start MyDraw.

Zoom Ribbon Group
The Zoom ribbon group lets you change the zoom mode of the drawing view to one of the following:

Normal: in this mode the drawing view zoom factor is not automatically calculated
Fit to Page: the drawing view is automatically zoomed in or our so that a whole page is shown in the available
area
Fit to Width: the drawing view is zoomed so that the whole width of the current page is visible
Fit to Height: the drawing view is zoomed so that the whole height if the current page is visible

You can use the Zoom In and Zoom Out buttons to zoom in and out the drawing view respectively. Alternatively you
can use the mouse wheel while holding with the Ctrl keyboard button or the following keyboard shortcuts:

Zoom In: Ctrl + "+"
Zoom Out: Ctrl + "-"
Zoom to 100%: Ctrl + "0"
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The keyboard shortcuts for zooming are identical to those of most modern web browsers, which makes them easy to
remember.

Settings Ribbon Group
The Settings ribbon group contains 5 buttons. When clicked each of them displays a dialog for editing the properties
of the object it's associated with:

Page: edits the properties of the active page. For more information check out the Page Settings topic.
Grid and Rulers: edits the properties of the grid and the rulers.
Routing: configures the routing manager and the routing settings.
Line Jumps: edits the line jumps settings.
Print Layout: edits the print layout settings.
Drawing Settings: configures the settings of the whole drawing view, for example the appearance of the
selection, whether to center selection on zoom, the copy/paste offset, the trackers appearance and many more.

4.6 Pan and Zoom View
The Pan and Zoom view allows you to move the active window to a different location of the drawing view or to
zoom in or out. To move across the drawing view simply drag the pan and zoom view rectangle with the left mouse
button. If you resize this rectangle using the tracers at its corners, then the drawing view will zoom in or out.

The following image demonstrates how to use the Pan and Zoom View to set the visible area of the drawing view.
Note how the visible area of the drawing view matches the red rectangle of the Pan and Zoom View. Changing the
size of the drawing area will be reflected in the Pan and Zoom view.
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4.7 Page Navigator
The page navigator lets you add, remove, rename and edit pages to your diagram documents and navigate through
these pages.

To add a page, click the Add button. To navigate to any page, click on the button with its name. The All expandable
menu is a listing of all pages in the document, again clickable to navigate to the page.

To rename a page, right click it and select Rename from the context menu.

To delete a page, right click it and select Delete from the context menu.

To create a duplicate of a page, right click it and select Duplicate from the context menu.

To edit the properties of a page, right click it and select Page Properties from the context menu. Page properties
include settings such as page orientation, page size, page selection mode, page border and background fill, the
coordinate system, layout and routing, and the print layout options.
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5 User Guide

5.1 Drawings
Create a new drawing
MyDraw by default opens with the New Drawing dialog, to create a new blank drawing or a drawing based on a
template. At any time you can also click File, then New (or press Ctrl+N) to start a new diagram.

Open a drawing
To open a drawing click File and then Open or press Ctrl+O from the keyboard. An "Open File" dialog will open in
which you can select the file you want to open. You can also drag and drop a compatible file format to the drawing
view of MyDraw and it will open automatically.

MyDraw also maintains a list of the recently used drawing documents at the right side of the application menu. You
can click any of the documents there to open it. You can also use the pin buttons next to each recent document to pin
it to/unpin it from the recent documents menu.

For a full list of the file formats supported by MyDraw, check out the File Formats Overview documentation topic.

Save a drawing
To save a drawing click File and then Save or press Ctrl+S from the keyboard. When you save your document for the
first time in this way, a Save File dialog will open in which you can specify the name and the type of the file MyDraw
should save your diagram to. If you want to save your drawing as a template, select the MyDraw XML Drawing
Template format.

The Save As menu item always shows the Save File dialog and lets you choose a file name and type. The Save As
menu item also provides a submenu of commonly used file types that lets you quickly choose a file format to save
your document in.

For a full list of the file formats supported by MyDraw, check out the File Formats Overview documentation topic.

Note that if you want to preserve all features and formatting of your drawings, you should always save them in
one of the MyDraw native formats (NDX or NDB). If you need a drawing in another format, you can then save it
to another format, too, but it is recommended that you awlays save it to a native MyDraw format first if you plan
to edit it later.
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5.2 Drawing Templates
MyDraw comes with a large number of drawing templates, which you can use to quickly create diagrams. The
predefined templates are displayed in the "New Drawing" dialog, which opens when you start MyDraw or when you
click the New menu item from the MyDraw's application (File) menu.

Loading a predefined template
To load one of the predefined templates, select it in the "New Drawing" dialog. At the root level of the dialog you can
also select the options "Blank Drawing", to create a new blank drawing and "New from Existing...", to create a new
drawing from an existing one. For more information about this dialog, check out the New Drawing Dialog topic.

Custom templates
If you want to create a custom MyDrawing template,  do the following:

1. Create a drawing as usual.
2. If you wish, you can use the Predefined Libraries button of the library browser to close the unneeded

predefined shape libraries and leave only the ones related to your template. To do this, click the Uncheck All
button placed below the list of shape libraries, check the ones you will use in your drawing and click OK.

3. Finally, click the Save As... menu item from the MyDraw's application (File) menu and save the drawing
as "Nevron XML Drawing Template (*.ndtx)".

Thus, your drawing template will be created and will appear in the "New from Existing..." option of the New Drawing
Dialog to be able to create a new drawing based on your custom template.

5.3 Drawing Tools
MyDraw comes eqipped with a set of Drawing Tools, found in the Home ribbon tab in the Tools section. These tools
allow the user to quickly create shapes and connectors without using pre-defined library shapes.

Rectangle Tool
The Rectangle tool allows you to create free-form rectangles in the drawing area. Select it by choosing the Rectangle
tool button.

 

Ellipse Tool
The Ellipse tool allows you to create free-form ellipses (including circles) in the drawing area. Select it by choosing
the Ellipse tool button.
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Line Tool
The Line tool allows you to create a straight line from one point to another. This is the most basic type of connector
line.

 

Cubic Bezier Tool
The Cubic Bezier tool allows you to create a line which has a double curve bend in the middle. for more flexibility in
your diagram shape placement and subsequent connections.

 

 

Arc Tool
The Arc tool creates a 1D object, usable as a connector as well, which is a half-circle arc. The depth of the arc can be
modified by adjusting the Modify Arc Bow box after the arc has been drawn.

 

 

Elliptical Arc Tool
The Elliptical Arc tool creates a 1D object, usable as a connector as well, which is a half-circle arc. The depth of the arc
can be modified by adjusting the Modify Arc Bow box after the arc has been drawn.
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Nurbs Tool
The Nurbs tool is a freehand line drawing tool, also used to make connections

 

 

Pointer Tool
The Pointer tool is used for selecting shapes and other objects.

 

Edit Geometry
The Edit Geometry tool is used to edit the geometry of drawn shapes, for example, to reposition key points in a
freehand drawn Nurbs tool line.

 

Connector Tool
The Connector tool allows the user to connect to a port on a shape, and draw a horizontal line with a 90 degree
vertical bend in it to connect to another shape.

 

Text Tool
The Text tool allows the user to create a text box.
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Pan Tool
The Pan tool is used for moving the drawing area in the visible frame with the mouse, rather than with the frame
sliders.

 

5.4 Inserting Images
The Insert tab page of MyDraw's ribbon allows for image import.

 

To insert an image click the Image button of the Insert tab. A file dialog for selecting an image file will open. MyDraw
currently supports the following image formats:

Bitmap
GIF, including animated GIFs
JPEG
PNG
Nevron Raster Image (NRI)

Alternately, you can insert images in your drawing by filling a shape with an image. To do so, right click a shape,
choose Format Geometry from the context menu and from the submenu select Geometry Fill. The Fill Editor dialog
will open. In that dialog select Image Fill for fill type as shown on the following screenshot:
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Click the Browse for image button to select an image to fill the shape with. If the image is an animated GIF, check the
Enable Frame Animation check box to insert it as an animated image.

Using the Texture Mapping button you can specify how the selected image should fill the shape - centered,
stretched, tiled, or aligned to a specific side or corner.

The Enter image URL button lets you load an image from the Web.

All images inserted in MyDraw are embedded in your drawings, which means that are source independent. In
this way, MyDraw drawings are self-contained and do not have reference dependencies.

5.5 Application Options
You can configure various aspects of MyDraw's appearance and behavior. To access the application's options, open
the File menu and click the Options button. The application options dialog will open:

MyDraw's application settings are organized into 3 tab pages:

Appearance Settings
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The application settings lets you configure the following:           

UI Theme: specifies the UI theme to use.
Language: specifies MyDraw's display language.
Contextual Help Mode: specifies the contextual help mode used in property editors. Can be one of the
following:

Collapsed: contextual help is not shown.
Focused Element: contextual help for the focused element is shown. This is the default value
Hovered Element: contextual help for the element the mouse is over is shown.

Developer Mode: if checked MyDraw will run in developer more showing you more settings and option to set
expressions to the properties shown in most dialogs.

Behavior Settings
The General tab lets you configure the following:

Auto Save Interval: defines the time interval for auto-saving the currently opened document. By default it is
set to 1 minute, which means that MyDraw will save any unsaved changes to your document every minute and
offer document recovery in case of an unexpected shut down or crash. To change the auto-save interval simply
select the desired time from the drop down list. To disable the auto-save feature select "Not Defined".
Email Send Settings: lets you configure the email send settings MyDraw uses when sending e-mail messages
as a result of a mail merge operation.
Automatically Check for Updates: specifies whether MyDraw should automatically check for updates.
Warn When Saving to Non-Native Format: if checked, MyDraw will show a warning message that saving to a
document format other than the native MyDraw document formats (NDX and NDB) may lead to loss of
information and formatting.

Documents Settings
The Documents tab lets you configure the Author and Company name that will be applied to each new drawing you
create with MyDraw.

5.6 Pages

5.6.1 Pages Overview
Each MyDraw drawing can have one or more pages. You can easily add, remove and rename pages using the Page
Navigator. You can also use the page navigator to switch to a different page.

The sections below describe how to perform some common tasks on the current page.

Change page size and margins
To change the size of the current page, right click somewhere in it and from the context menu that appears, select
Page Properties... The page properties dialog will open. In it, take a look at the "Size" group box in the "General" tab
page and use the "Page Size" and "Page Orientation" combo boxes to set the size and the orientation of the current
page, respectively. The "General" tab page also lets you change the page margins.

Change page background and border 
To modify the appearance of the page, right click somewhere in it and from the context menu that appears, select
Page Properties... In the page properties dialog, select the "Appearance" tab and use the property editors in it to
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modify the background, the border and the border thickness of the page.

Change page drawing scale
MyDraw uses a special measurement unit for all display related measures, which is the DIP (device independent pixel
that is 1/96 of an inch). By default the drawing scale is configured so 1 DIP equals 1 DIP (identity scale).

Some drawings, however, require to display either too small or too large scenes, which are impossible to visualize
without a drawing scale. In order to visualize them in a comfortable for you manner you can use the drawing scale
options.

The drawing scale is a user defined ratio between the logical unit and the display unit. For example, 1 meter = 1 mm
is a commonly used Metric drawing scale. This means that 1 mm of your drawing represents 1 meter of the real world
space.

You can change the page drawing scale from the "General" tab of the page properties dialog, or you can simply right
click one of the drawing view rulers and select Change Drawing Scale from the context menu. Then in the dialog that
appears you can either enter the drawing scale manually from the measure up-down buttons or click the Load
Drawing Scale button to select one of the predefined drawing scales. Changing the drawing scale will also change
the measurement units of the ruler and the measurements of the currently selected diagram item, which are shown in
the status bar.
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5.6.2 Page Settings
To edit the settings of a page, right click it in the page navigator and select Page Properties. Alternatively, you can
right click anywhere in the page and select Page Properties from the context menu. As most property editors in
MyDraw, the page property editor is organized in tabs.

Size and Scale
MyDraw’s default page size is A4 portrait. The first two settings in the page property editor are the Drawing Scale and
Size. Depending on your needs you can modify the drawing scale or the size of the page.

Padding
Page padding is the spacing applied to the page when you size it to its content by right-clicking somewhere in the
page and selecting Size to Content.
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Appearance
To change the background color and border of the page of your diagram, go to the Appearance tab. To edit the main
color, select Background and choose the type of fill you’d like to use. You will find plenty of opportunities including
Color Fill, Stock, Linear, Radial, or Advanced Gradient Fill, Hatch or Image Fill. Each of those fill types can be
additionally modified to achieve the result you’re looking for.

To edit the border of your page, click the Border button and choose the type, color, and rounding of the border. Don’t
forget to also specify border thickness. With MyDraw you can choose to have a border on all sides of your drawing
area or on specific sides only.

Page Items
The tree view on the left side of the dialog shows the page hierarchy. Of special interest is the Items collection. It
contains all items that are placed in the page, for example shapes, groups, guide lines, etc. You can see the items by
expanding the Items collection and you can click any of the items to inspect and modify its properties.

5.6.3 Page View
In the View ribbon tab, there are a number of settings which you can use to manipulate the drawing area view how
you see fit. The default page view is as shown:

 

Page View Mode and Zooming
There are four types of page view modes available. Pages modes will automatically change their values based upon
the printable page value set for the project (i.e. Letter, A4, A3, Legal)

Normal: This mode shows the drawing area at the default settings

Fit to Page: This mode will show the area of a full printed page in the drawing area

Fit to Width: Fit to Width will show the area of the width of a printed page in the drawing area, disregarding the
height

Fit to Height: Fit to Height will show the area of the height of a printed page in the drawing area, disregarding the
width
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Show/Hide Page Elements
In the Show area of the View ribbon tab, there are 5 checkbox settings which change the visual aspect of the drawing
area. They are:

 

Grid: This setting, when checked, shows the grid pattern in the drawing area.

Guidelines: When activated, any guidelines you have made will be visible

Page Breaks: Shows finely dotted lines at the edge of what would be a printed page

Ports: Shows the ports on all shapes in the drawing area

Rulers: When activated, the horizontal and vertical rulers will be shown

 

These settings are also accessable by right clicking on a blank spot of the drawing area to access the context menu
and hovering over the View dropdown menu.

Change page size and margins
To change the size of the current page, right click somewhere in it and from the context menu that appears, select
Page Properties... The page properties dialog will open. In it, take a look at the "Size" group box in the "General" tab
page and use the "Page Size" and "Page Orientation" combo boxes to set the size and the orientation of the current
page, respectively. The "General" tab page also lets you change the page margins.

5.6.4 Grid, Rulers and Guidelines
Gridlines and Rulers
 MyDraw drawings are equipped with a grid patter by default, which is aligned to the horizontal and vertical rulers on
the page. Not only does this allow for precise sizing and alignment, this function also enables the Snap and Glue
functions to help you align a drawing's shapes perfectly.

 

To change the units and drawing scale, see the Drawing Scale topic. To zoom in or out, which will either decrease the
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step size of the ruler and simultaneously increase the percieved grid size, hold Cntl+Scroll Up, and to increase the
step size and decrease the grid size hold Cntl+Scroll Down.

Alternately, you can go to the View ribbon tab and choose your zoom factor from the Zoom area.

 

To manipulate the grid to your exact specifications, go to the View ribbon tab and click on the Grids and Rulers
button. This will open up the Grids and Rulers editor.

 

Guidelines
Guidlines are an important part of precision shape placement in MyDraw.  Guidelines are Grid and Ruler independent,
allowing the user to add arbitary (yet unprinted in the final product) gridlines for alignment and snapping purposes.
To add a Guideline, hover the mouse over either the horizontal or the vertical ruler. The cursor will shift to a double
arrow. Click, hold and drag to place a guideline in the drawing area.
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You can right click on each individual guideline to change their properties, including adding a name, choosing the
exact pixel position, appearance aspects, and change it's protection properties, for example making it unselectable
and therefore unmoveable, allowing the guideline to be printed, removing the ability to delete it, and removing a
context menu for the item.

 

 

5.6.5 Drawing Scale
Change Page Drawing Scale
MyDraw uses the basic measurement unit for all display related measure ment of px, or pixel, which is DIP (device
independent pixel, at 1/96 of an inch). By default the drawing scale is configured so that 1 DIP equals 1 DIP (identity
scale).

Some drawings, however, require displaying either too small or too large scenes, which are impossible to visualize
without a drawing scale. In order to visualize them better, use the drawing scale options.

The drawing scale is a user defined ratio between the logical unit and the display unit. For example, 1 meter = 1 mm
is a commonly used Metric drawing scale. This means that 1 mm of your drawing represents 1 meter in real world
space.

There are 5 drawing scale systems native to MyDraw. They are:

Abstract Drawing: Pixel units
Metric: Metric Units
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Architechtural: US (Imperial) Units
Mechanical Engineering: Metric Units
Civil Engineering: Us (Imperial) Units

 

You can change the page drawing scale from the "General" tab of the page properties dialog, or right click one of the
drawing view rulers and select Change Drawing Scale from the context menu. In the dialog that appears, you can
either enter the drawing scale manually from the measure up-down buttons or click the Load Drawing Scale button
to select one of the predefined drawing scales. Changing the drawing scale will also change the measurement units of
the ruler and the measurements of the currently selected diagram item, which are shown in the status bar.

 

 

5.7 Shapes

5.7.1 Shapes Overview
Add a shape
Adding a shape in MyDraw is very easy - simply drag and drop any shape you like to add to your diagram from the
library browser to the drawing area of MyDraw as shown in the following image:
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Select, move, resize and rotate a shape
To select a shape either click it or click and hold somewhere outside of it and then drag to
trigger the rectangular selection tool and select it. When the shape is selected a set of trackers
will appear around it as shown in the picture to the left.

To move a shape simply select it and drag it across the drawing area until you reach the
desired location.

To resize a shape, drag one of its corner trackers.

To rotate a shape use the circular tracker above the shape. You can also use the buttons in the
Rotate ribbon group of the Action tab from the ribbon.

Multi selection and anchor shapes
When two or more shapes are selected MyDraw it becomes ambiguous on which shape some commands should
work, for example the align lefts command. To visualize which shape will be used for such commands, MyDraw
introduces two types of anchor shapes:

Alignment anchor - the shape that will be used by alignment commands. The trackers of the alignment anchor
are filled in black.
Format anchor - the shape that will be used by formatting commands. The trackers of the format anchor are
filled in white.

If a shape in multi selection is both alignment and a format anchor, then its trackers are filled in white, i.e. the coloring
of the format anchor takes precedence.

The following image shows how a selection with a different alignment and format anchor looks:
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In this case the red line is the format anchor and the orange rectangle is the alignment anchor.

Format shape's geometry
To change the appearance of a shape use the split buttons in the Geometry Format ribbon group of the Home tab.
They will let you change the fill, stroke and shadow of a shape, as well as its corner rounding. If the selected shape is a
1D shape (i.e. a connector) you can also change its start and end arrowheads.

To pick the geometry formatting of the selected shape or the format anchor shape in case of multiple selected shapes,
click the copy geometry formatting button (the rightmost pipette on the image below). Then select one or more
shapes and click the apply geometry formatting button (the rightmost brush on the image below).

 

Add text to a shape or to the page
To add text to a shape, activate the Pointer tool (the one that looks like an arrow) and double click the shape or
directly start typing. An in-place rich text editor for entering/modifying the text of the shape will open. You can use
the buttons in the Font and Paragraph ribbon groups to format and style the text of the shape. Note that in text edit
mode the text formatting ribbon commands act on the text selected in the rich text editor, but if you have simply
selected the shape and you have not entered in text edit mode, the text formatting ribbon commands modify the
formatting of the whole text of the shape.

When you have finished entering text press Escape from the clipboard or click outside of the shape to apply the text
change. If you want to cancel the text change and revert to the previous text of the shape press Shift + Escape from
the keyboard.

If you want to simply add some text to the page, then activate the Text tool (the one that looks like the letter "T"),
click and hold somewhere in the page and drag to create a text area. Then double click this text area and enter your
text.

Format shape's text
If you want to format the whole text of a shape at once you can simply select the shape and use the controls in the
Font and Paragraph ribbon groups.
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To format only parts of the shape's text, you should double click the shape in order to enter in in-place edit mode.
You should then select the text you want to style and use the controls from the ribbon to apply the desired formatting
to the selected text. You can then select another piece of the text and format it differently and so on.

You can use the copy (the pipette) and apply (the brush) text formatting buttons to copy the text formatting of a
shape and then apply it to one or more shapes in the same way you do for shape geometry.
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5.7.2 Editing Shapes
Shapes dropped to the drawing view from the library browser by default contain one or more ports, so you can easily
attach connectors to them. If you create a shape using the MyDraw's drawing tools or you simply want to add more
ports to your shape, you should right click the shape and select Shape Properties... The following dialog will open:

The tree view at the left side of the dialog shows the shape children and the controls at the right side lets you edit the
properties of the item currently selected in the tree view.

Info panel
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The info panel at the bottom of the dialog shows information about the currently edited (focused) property. For
example at the screenshot above it shows information about the "Resize in Group" property of the shape. When the
property info panel is not large enough to show the description of the property, it displays an arrowhead pointing
upwards as shown on the screenshot. Click it to expand the info panel and see the whole description for the currently
edited property.

To switch the contextual help mode of the application and show information not for the currently edited property but
for the property the mouse cursor is over, click the question mark button of the info panel. Click it again to switch
back to focused element contextual help mode.

If don't need contextual help in property editors then click the Close (the 'X') of the info panel to close it. You can later
enable the info panel again from the "General" tab of the program options (File -> Options).

Add and remove ports
If the shape does not have any ports, the ports collection may not be present, too and you will have to create it. To do
so, select the shape in the tree view and click the Add button (the green plus) in the toolbar placed below the tree
view. In the dialog that open select Ports (Port Collection) for child type and a ports collection will be added for the
shape. Then select the ports collection in the tree view and use the Add button to add one or more ports to it.

When you add a port, the easiest way to configure its location is to select the "Relative" check box to make its position
relative to the shape bounds and then set the X and Y fields in the Location group box to values from 0 to 1, where
(0, 0) denotes the top left corner of the shape's bounding box and (1, 1) denotes its bottom right corner. For example,
to create a port at the center of the right side of the shapes bounding box, you should set X to 1 and Y to 0.5.

To remove a port, select it in the tree view and click the Delete button (the red "X") from the toolbar or press the
Delete key from the keyboard.

5.7.3 Connectors
Connect two shapes
To connect two 2D shapes you can use the Line or the Connector tool. These tools are in the Home tab of the
Ribbon. Once you’ve selected the connector type you would like to use, click on a port of the shape you want the
connector to start from, then drag the mouse cursor to a port of the shape you want the connector to end at.

When the mouse is over a port or the contour of a shape, it will highlight in red, indicating a valid point for the
start/end of the connector. The following image shows the result of using the Line tool to connect a rectangle and an
ellipse.

Connector splitting
You can split a connector into multiple parts when moving an existing or dropping a new 2D shape over a 1D shape
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Before splitting:

or end-point. The result of the operation is visually highlighted, so that the user knows whether connector splitting or
automatic connection to the end-points will occur.

The following images illustrates 1D Shape splitting:

After splitting:
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Before automatic connection:

For 1D Shape splitting to occur the following conditions must be met:

1. The moved 2D shape CanSplit property needs to be set to true (which is the default).
2. The target 1D shape to be split splitting needs to have its Splittable property set to true.
3. Both the begin and end points of the 1D shape need to be outside of the moved 2D shape bounds.

The CanSplit and Splittable properties can be modified from the shape properties – layout tab.
1D Shape splitting can be globally disabled by the Page – Interaction – Enable 1D Shape Splitting setting. By default
1D Shape splitting is enabled.

Automatic connection to 1D Shape end-points
The following images illustrate the automatic connection to 1D Shape end-points:

After automatic connection:

Automatic connection to 1D Shape end-points automatically glues the begin point of the connector to the dropped
2D shape.
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For automatic connection to 1D Shape end-points to occur the following conditions must be met:

1. The moved 2D shape must be over one of the end points
2. The respective property in the Page – Interaction (i.e. Enable Connect Begin Points or Enable Connect End

Points must be set to true).
3. The target 1D shape needs to have its Splittable property set to true.

The automatic connection to 1D Shape end-points feature can be globally disabled by the Page – Interaction – Auto
Connect To Begin Points and Auto Connect To End Points settings.

5.7.4 Shape Hyperlinks
MyDraw makes it easy to create shape hyperlinks. When you Ctrl + Click (Cmd + Click on Mac) a shape with a shape
hyperlink, this link the shape's hyperlink points to will open.

The following list describes how to insert, edit and delete shape hyperlinks:

To insert a shape hyperlink right click a shape and select Insert Shape Hyperlink... from the context menu or
select the shape, open the Insert ribbon tab and click Shape Hyperlink. Configure the shape hyperlink
properties in the dialog that opens and click OK.
To edit a shape hyperlink, right click a shape with a shape hyperlink and select Edit Shape Hyperlink... from
the context menu.
To delete a shape hyperlink, right click a shape with a shape hyperlink and select Delete Shape Hyperlink
from the context menu.

The tooltip (mouse-over text) of the shape hyperlink is by default automatically determined by the type of the
hyperlink, but you can override it by setting the Description field of the shape hyperlink. The following image shows
the default tooltip of a shape hyperlink to a page.

MyDraw supports the following types of shape hyperlinks:

Hyperlink to URL
The URL hyperlink points to an URL web address:
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Hyperlink to File
The file hyperlink points to a local file:

Hyperlink to Page
The page hyperlink points to a page in the same document. You can use the Zoom Percent field to specify the zoom
percent to apply when opening the linked page:

Hyperlink to Shape
The shape hyperlink points to a page in the same document. You can use the Zoom Percent field to specify the zoom
percent to apply when opening the page of the linked shape:

Hyperlink to Bookmark
The bookmark hyperlink points to a bookmark in the same document.
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For more information about creating and using bookmarks, check out the Bookmarks topic.

5.7.5 Snap and Glue
MyDraw includes a number of “snap to” settings so when you move or resize shapes or connectors, the selected
object(s) will automatically snap to grids, guides or other objects. The snap settings are available in the Arrange tab,
including “Snap and Glue”, “Snap to Grid”, “Snap to Rulers” and “Snap to Guidelines”.

 

 

When selecting the “Snap and Glue” option, the Snap and Glue Editor window will appear, allowing you to customize
the Snap and Glue settings to your preferences.

 

 

The glue options will keep your shapes and connectors attached. When moving a shape, the connectors will
automatically reconfigure themselves and their paths to accommodate the new shape positions, without necessitating
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reattaching connectors.

     

For example. In example1, the connector line is glued to ports on both the circle and triangle.  When the circle is
moved (example2), the connecter line automatically moves to accommodate the new object configuration.

 

5.7.6 Custom Shapes
MyDraw comes with a large library of predefined shapes. If none of them is suitable for your diagram, you can create
a custom shape that suits your needs. MyDraw provides several methods for creating custom shapes:

Generating Custom Shapes
Shape composition is the process of combining the geometry of two or more shapes into one. To compose a complex
shape, create and position two or more shapes, select them either by Crtl+Clicking all of them, or by rectangular
selection. Then use one of the buttons in the Compose ribbon group of the Action tab page. The image below
demonstrates the result of different shape composition operations on a square and 4 triangles.

Drawing Shapes
MyDraw also lets you draw shapes using lines, cubic beziers, arcs or freehand drawing (Nurbs tool). To draw a custom
shape, select one of these draw tools and start creating primitives (lines, curves, arcs, etc.) or create a freehand
drawing using the Nurbs tool. Each time you place the mouse cursor over the start or the end of a primitive MyDraw
will show a tooltip to remind you that you can extend the current geometry from this point. If a primitive you are
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drawing closes a geometry at any given point, a tooltip "Close Geometry" will appear to inform you that at this point
the geometry will be closed and a 2D shape will be produced.

You can use the "Edit Geometry" tool (the pencil) to modify the control points of the geometry primitives in order to
change the outline of the shape.

5.7.7 Arranging Shapes

5.7.7.1 Arranging, Moving, Duplicating And Resizing
Shapes

As MyDraw’s primary drawing area is made of shapes and connectors, arranging shapes is an integral part of the
program’s usage. In the Arrange tab of the ribbon bar, you will find options for alignment, resizing, positioning, Z-
order, spacing, grid alignment, snapping and shape layout.

For all shape alignments and comparative resizing, the last shape selected being the shape which will stay static, i.e.
the other shapes will be moved to align with it. The shape which will be aligned to (the last one selected, which is
static) will be outlined with a thick black border, while alignment shapes will have thinner, blue borders.

Moving and Duplicating Shapes
To move a shape, select it and drag it across the drawing area until you reach the desired location.

To duplicate a shape, select it, hold down the shift key and drag the duplicate shape to your desired location. You can
also right click on any shape to access the context menu, and copy, then right click somewhere else and paste the
shape(s). Alternately, Ctrl+c will copy the selected shape(s), and Ctrl+v will paste them underneath the cursor

Resizing Shapes
To resize a shape, drag one of its tracker points in any direction. For more precise resizing, right click on the shape,
and choose Shape Properties… from the context menu. The Shape Editor dialog will appear. Click on the Transform
tab at the top right to access the settings with more precise controls.
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To resize a shape in relation to another shape, go to the Arrange ribbon tab and the Resize group.

There are four options available, including:

Make Same Width: This will make two or more shapes the same width of the last selected shape.
Make Same Height: This will make two or more shapes the same height of the last selected shape.
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Make Same Size: This will make two or more shapes take up the same amount of grid square shape area that
last selected shape occupies. Grid square shape area is calculated by MyDraw as taking the furthest left, right,
bottom and top pixels of an object and creating a rectangular box out of them. The shape area grid space can
clearly be seen with by the object outlines which appear when selected.
Size to Grid: This will make the shape size itself to the nearest grid lines. Note that certain shapes will have a
locked aspect ratio which will need permission to use this function

5.7.7.2 Selection and Anchor Shapes
When two or more shapes are selected MyDraw it becomes ambiguous on which shape some commands should
work, for example the align lefts command. To visualize which shape will be used for such commands, MyDraw has
two types of anchor shapes:

Alignment anchor - the shape that will be used by alignment commands. The trackers of the alignment
anchor are filled in black.
Format anchor - the shape that will be used by formatting commands. The trackers of the format anchor are
filled in white.

If a shape in multi selection is both alignment and a format anchor, then its trackers are filled in white, i.e. the coloring
of the format anchor takes precedence.

The following image shows how a selection with a different alignment and format anchor looks:

In this case the red line is the format anchor and the orange rectangle is the alignment anchor.

Aligning Shapes
To align your shape, first select the two or more shapes you need to align. Go to the Arrange ribbon to the Align
group. There are six options:

 

Align lefts: This option will align the leftmost pixel of both shapes along the same vertical line.
Align centers: This option will align the rightmost pixel of both shapes along the same vertical line.
Align rights: This option will align the center pixel of both shapes along the same vertical line.
Align tops: This option will align the topmost pixel of both shapes along the same horizontal line.
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Align middles: This option will align the exact middle of both shapes along the same horizontal line.
Align bottoms: This option will align the bottommost pixel of both shapes along the same horizontal line.

Z-Order
Z-Order is the order of precedence that the shapes in the drawing area have over one another.  This basically means
which shape is on top, the shape below it, and which is on bottom.  The Z-Order area of the Arrange ribbon tab has
four options:

Bring to Front: This option will move a selected shape to the front of the Z-Order (on top of all other objects)
Send to Back: This option will move a selected shape to the back of the Z-Order (behind all other objects)
Bring Forward: This option will send the shape one level up in the Z-order
Send Backward: This option will send the shape one level down in the Z-order

Grouping and Ungrouping Shapes
Grouping and ungrouping shapes allows the user to create a grouping of shapes so that their location and connectors
may be manipulated together, rather than individually. Groups support drill down selection, which means that you can
select a shape within the group by first clicking on the group to select the group and then clicking on the particular
shape within the group to select it.

To creating a group of two or more shapes, select them with a selection box, or Ctrl-Click on each one in succession,
and click on the Group button from the Action ribbon tab or use the shortcut Ctrl+Shift+G. You can group not only
shapes but also multiple groups. When a set of shapes are grouped together they will act as one shape, allowing for
resizing and rotation together.

To ungroup a set of shapes, or groups,  click the Ungroup button from the Action ribbon tab or
press Ctrl+Shift+U from the keyboard.

 

5.7.7.3 Shape Protections
Most shapes in MyDraw can be extensively manipulated. If you wish to keep an aspect about a shape from being able
to be modified, or all aspects, shape protections can be applied.

To get to shape protection settings, right click on any shape, and choose “Shape Properties…”

The shape editor window will appear. Click on the “Protection” tab to access the Shape Protections settings.
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5.7.7.4 Grouping and Ungrouping Shapes
Grouping and ungrouping shapes allows the user to create a grouping of shapes so that their location and connectors
may be manipulated together, rather than individually. Groups support drill down selection, which means that you can
select a shape within the group by first clicking on the group to select the group and then clicking on the particular
shape within the group to select it.

To creating a group of two or more shapes, select them with a selection box, or Ctrl-Click on each one in succession,
and click on the Group button from the Action ribbon tab or use the shortcut Ctrl+Shift+G. You can group not only
shapes but also multiple groups. When a set of shapes are grouped together they will act as one shape, allowing for
resizing and rotation together.

To ungroup a set of shapes, or groups,  click the Ungroup button from the Action ribbon tab or
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press Ctrl+Shift+U from the keyboard.

5.7.7.5 Set Operations with Shapes (Union, Intersection
etc.)

MyDraw features shape set operations. When overlapping two or more shapes in the drawing view and selecting both
of them, the set operations in the Action ribbon bar tab, in the Compose group, will become available.

 

The following image is a base image before set operations have been used on the shapes contained therein:

Set operation options include 4 options, including:

Union: This option merges all shapes together into one shape with one contiguous outline. For all intents and
purposes, including settings and usage scenarios, it is one shape.

 

Intersect: Intersect will leave only the area that each shape of those selected overlapped each other.
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Subtract: This option will subtract all shapes from the topmost shape in the group. In our example, as the triangle was
on top, only pieces of it are left. For stacking order, refer to Z-Order.

 

Exclusive Or: Exclusive or will remove areas of overlap in the case of an even number of objects overlapping an area,
i.e. 2, 4 or more object areas overlapping. In the case of an odd number of overlapping object areas, such as 3, the
overlapped area will be preserved.

 

 

5.7.7.6 Z-Order
Z-Order is the order of precedence that the shapes in the drawing area have over one another.  This basically means
which shape is on top, the shape below it, and which is on bottom.  The Z-Order area of the Arrange ribbon tab has
four options:
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Bring to Front: This option will move a selected shape to the front of the Z-Order (on top of all other objects)
Send to Back: This option will move a selected shape to the back of the Z-Order (behind all other objects)
Bring Forward: This option will send the shape one level up in the Z-order
Send Backward: This option will send the shape one level down in the Z-order

5.7.8 Formatting Shapes

5.7.8.1 Formatting Shapes Overview
Each shape in MyDraw can be formatted, to add styles, geometry changes, add text blocks, outlines and shadows, etc.
There is a high level of customization options available for each shape, some more than others.

Editing Geometry
To edit the geometry of a shape, right click on the shape and choose Shape Properties… The Shape editor dialog will
appear.
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There are 5 settings tabs in the shape editor, including:

Behavior - Here you can name the shape, and choose how the shape behaves within the program
Transform - Here you can manipulate the size, x and y axis, position and relative location settings
Move and Glue - The area to choose the default shape glue settings, and slave shape settings
Protection - This tab allows you to restrict editing options on the shape, including the ability to change the
aspect ratio
Arrange - Slot placement and connector splitting options, including routing options

To the left side of the tabs are sub-menus gives additional options for the geometry and port options.
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Formatting Geometry
To change the appearance of a shape use the split buttons in the Geometry Format ribbon group of the Home tab.
They will let you change the fill, stroke and shadow of a shape, as well as its corner rounding. If the selected shape is a
1D shape (i.e. a connector) you can also change its start and end arrowheads.

To pick the geometry formatting of the selected shape or the format anchor shape in case of multiple selected shapes,
click the copy geometry formatting button (the rightmost pipette on the image below). Then select one or more
shapes and click the apply geometry formatting button (the rightmost brush on the image below).

Shape Size, Position and Rotation

To select a shape either click it or click and click and hold outside of the shape and drag to trigger the rectangular
selection tool, then drag it to cover and select the shape. When the shape is selected, a set of trackers will appear
around it as shown in the picture to the left.

To rotate a shape use the circular tracker above the shape. You can also use the buttons in the Rotate ribbon group
of the Action tab from the ribbon.

Themes
On the Design tab, you can choose the Page Theme and Page Theme Variants. Themes apply to a whole drawing
page. They consist of a set of shape styles with fill, stroke and text styles that blend well with each other.  Choosing a
page theme will change, and nearly all visual aspects of the page and shapes, excluding shape geometry. The default
theme is MyDraw Nature, Variant 1.

For more information check out the Themes And Shape Styles topic.

Formatting Text Blocks
To create a text block, choose the T button from the home tab, and click, hold and drag anywhere in the drawing
area. 

Double click in the text box that appears, and type your text. On Home tab, you can find options for font, bold, italic,
underline, etc.
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In addition to the normal options, there are four additional option menus. You can access them either from the text
section of the home menu, or right click anywhere in the box and hover over the “Format Text Block” menu to show
the options available.

The options are:

Text Fill: A dialogue window will appear, allowing you to choose the different types of text fill
Text Background Fill: This menu allow you to choose the style and color of the text background filler
Text Stroke: A menu to allow you to select the stroke options
Text Shadow: Options for text shadow.

 

5.7.8.2 Themes and Shape Styles
MyDraw themes and styles make it easy to quickly change the appearance of your shapes and even the whole
drawing page.

Themes
Themes apply to a whole drawing page. They consist of a set of shape styles with fill, stroke and text styles that blend
well with each other. This allows you to quickly style your diagram with a polished and professional look.

To change the theme of a drawing page, click it in the page navigator to make it the active page and the open the
Design ribbon tab.

The image below shows all styles in the "MyDraw Nature" theme, which is the default theme applied to new
documents in MyDraw.
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If you select the Office theme and then select it's fourth variant, you will get the following:
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As you can see, themes and their variants change the appearance of all shapes on the page. If you want to change the
style of specific shapes, then you should use shape styles.

Styles
After you select a theme and a variant for the page, you can style individual shapes with a shape style. Shape styles for
the currently selected theme and variant are accessible from the Design tab of the ribbon. Select one or more shapes
and then click a shape style from the ribbon to style them with this shape style. The selected shapes will then be styled
with the selected shape style. If you change the theme and/or the theme variant of the page, then all shapes styles will
be automatically updated to reflect the newly selected theme and variant.

The screenshot below shows how the shape style ribbon gallery looks:
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5.7.8.3 Shape Properties
To edit the geometry of a shape, right click on the shape and choose Shape Properties… The Shape editor dialog will
appear.

 

 

There are 5 settings tabs in the shape editor, including:

Behavior - Here you can name the shape, and choose how the shape behaves within the program
Transform - Here you can manipulate the size, x and y axis, position and relative location settings
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Move and Glue - The area to choose the default shape glue settings, and slave shape settings
Protection - This tab allows you to restrict editing options on the shape, including the ability to change the
aspect ratio
Arrange - Slot placement and connector splitting options, including routing options

To the left side of the tabs are sub-menus gives additional options for the geometry and port options.

 

 

5.7.8.4 Shape Size, Position and Rotation

To select a shape either click it or click and click and hold outside of the shape and drag to trigger the rectangular
selection tool, then drag it to cover and select the shape. When the shape is selected, a set of trackers will appear
around it as shown in the picture to the left.

To rotate a shape use the circular tracker above the shape. You can also use the buttons in the Rotate ribbon group
of the Action tab from the ribbon.

 

 

5.8 Text

5.8.1 Rich Text Formatting
To add text to a shape, activate the Pointer tool (the one that looks like an arrow) and double click the shape or
directly start typing. An in-place rich text editor for entering/modifying the text of the shape will appear. The buttons
in the Font and Paragraph ribbon controls are to format and style the text of the shape. Note that in text edit mode,
the text formatting ribbon commands act on the text selected in the rich text editor.

When you have finished entering text, press Escape from the clipboard or click outside of the shape to apply the text
change. To cancel the text change and revert to the previous text of the shape, press Shift + Escape.

To add some text to the page, then activate the Text tool (the one that looks like the letter "T"), click and hold
somewhere in the page and drag to create a text area. Then, double click inside this text area and enter your text.

 

To format the entire text of a shape at once, select the shape and use the controls in the Font and Paragraph ribbon
groups.

To format only parts of a shape's text, double click the shape in order to enter in-place edit mode. Then, select the

MyDraw User Guide 65

©2020 Nevron Software. All Rights Reserved.



text to style and use the controls from the ribbon to apply the desired formatting to the selected text.

You can use the copy (the pipette), and apply (the brush), text formatting buttons to copy the text formatting of a
shape and apply it to one or more shapes in the same way as for shape geometry.

 

5.8.2 Inserting Symbols
To insert a symbol into a text field or table, click on the Symbol button in the Insert ribbon tab. It will open up a drop
down menu showing the most commonly used symbols, which will repopulate over time to reflect the users most
popularly used symbols.

To access the symbol library, click on the More Symbols… button from the drop down menu.  This will open up the
Symbol Library, which is broken down into selectable categories on the left, and a recently used symbols bar on the
bottom. You can select the font you wish the symbol to appear in, if available, from the top Font box.
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5.8.3 Automatic Text Fields
There are four automatic text fields available for insert in a text box. They are -

Hyperlink: Allows the user to insert a hyperlink into the text field, including the hyperlink text, url, and target frame
when clicked.

Date: The Insert Date and Time dialogue window box will pop up, giving the user a list of date and time formats to
insert. The checkbox near the bottom of the dialogue window box Update Automatically will have MyDraw update the
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date and/or time in this field automatically.

Time - The Insert Time dialogue window box will appear giving the user a list of time formats to insert. The checkbox
near the bottom of the dialogue window box Update Automatically will have MyDraw update the time in this field
automatically.
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Field - Allows the user to create an advanced field variable area within a text box. The Insert Field dialogue window
box will appear with a choice of field type, the format for the type, predefined formats per type, a preview pane, and
an explanation box below.
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5.8.4 Text Review and Spell Check
Text review is available under the Review ribbon tab. To check your written text in your project, click on the Spell
Check button. To change your review language, click on the Language button, and choose the language you wish to
proof with in the Language dialog window. 
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5.9 Tables

5.9.1 Inserting Tables
To insert a table, click on the Insert button on the far left of the Table ribbon bar. A grid box will pop up below the
button, allowing you to use the mouse to choose how many rows and columns the table you would like to insert will
be. A numerical value will appear at the top of the grid for quick understanding of the number of rows and columns
currently chosen.  When have the right numbers of rows and columns you wish your table to be, click on the box
where the mouse is located at present, and the table will appear in the center of the drawing area.

 

Inserting and Removing Rows and Columns
To insert a row in your table, use one of the four insert buttons in the Rows & Columns area of the Table ribbon bar.
These will insert a column or row in the direction you wish, based on what column or row you have selected in your
table. Alternately, you can right click on the table, and in the context menu hover over insert, and choose from the
same option list.

To remove a column, use the Delete button the Rows & Columns area. A drop down menu will allow you to choose to
delete a row, column, or the entire table. You may also choose these options in the right click context menu under the
Delete drop down menu.

Merging and Splitting Cells
To merge two or more cells, simply click, hold and drag to select more than one cell, and click on the Merge Cells
button to make one larger cell. A cell may only be split after it has already been merged. If multiple cell rows and
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columns have been merged, the option to split them horizontally or vertically will be selectable in the Merge area of
the Table ribbon tab.

Specifying Column Size
To specify your column width, click on the Columns Width button in the Table area. A drop down menu will offer three
choices, including:

Fixed: This will keep each row the width it currently has, and allows you to customize the table column
width to your liking using the mouse.
Percentage: This option will keep each row as an equal percentage of the width of the table
Fit to Content: This option will automatically change the table columns width based on the size of the text
and/or shapes within the table cells

To manually change the width of a column, hover the mouse cursor over any table border line, and a line with a small
arrow on either side will appear. Click and hold, and drag the border line to your desired sizing

 

5.9.2 Table Ports Mode
The Table Ports mode determines how you can link your table to other shapes within MyDraw. When you click on the
Table Ports Mode button in the Table area of the Table ribbon tab, there are 5 options to choose from:

None: This will remove the connectable ports from the table

Grid: Creates ports equally spaced around the borders of the table based upon its size

Cell: Creates a port for each cell

Rows Only: Creates a port on either side of rows, but not columns

Columns Only: Creates a port on either side of columns, but not rows

5.9.3 Table Style
When creating a table in MyDraw, it appears with the default cell borders, fill, and line thickness. These can all be
changed with the table styles group under the Table Style group in the Table ribbon tab.

The Cell Background Fill drop down menu adds options for the fill color and pattern. By choosing More Options...
you can access the Fill Style Editor, where you can choose more precise colors and fill transparency.
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The Cell Borders and Thickness drop down menu allows the user to choose a border style and thickness for each
cell, or a range of cells.  The More Options... button opens the Cell Border and Thickness Editor for even more
customization.
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5.9.4 Formatting Cells
Formatting Cells
You can format each individual cell in a table inserted into MyDraw. To do so, right click on any cell and choose Edit
Cell. The Edit Cell dialogue window will appear.  You can control the cell border and fill styles, color and rounding,
and the border thickness. From the Block tab, you can controll the margins and padding of the cell. The Cell tab
allows you to choose how many columns and rows a cell spans, and is another way to Merge cells. The size tab allows
you to choose your width and the minimum width of the cell. These values are in relation to sizes of the other cells in
the table.
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Editing Columns and Rows
You can also edit individual columns and rows in MyDraw tables. when right clicking on any cell, choose either Edit
Column or Edit Row, based on your preference. The Edit Column/Row dialogue box will appear, allowing you to
choose a border for the entire column or row, fill properties, border thickness, and size properties.
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Note that individual cell formatting will take precedence over row or column formatting.

5.10 Barcodes

5.10.1 Inserting Barcodes
The Insert tab page of MyDraw's ribbon lets you easily insert 1D and 2D barcodes.

Insert a 1D barcode
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To insert a 1D (a.k.a. linear) barcode, click the 1D Barcode button of the Insert tab. The following dialog will open:

In this dialog you can configure the scale and the size mode of the barcode, its background and text fill, its symbology
and text. Note that some symbologies have strict requirement on the text of the barcode, for example an EAN13
barcode can only have 13 digits (12 digits + 1 check digit).

If you enter "0123456789012" in the dialog above, the following 1D barcode will be created:

Insert a 2D barcode
To insert a 2D (a.k.a. matrix) barcode, click the 2D Barcode button of the Insert tab. A dialog similar to the one for 1D
barcode will open. It will let you configure the scale and size mode of the barcode, its background and text fill, its
symbology and text. MyDraw currently supports the following 2D barcode symbologies:

QR code

Data Matrix
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PDF 417
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5.11 Presentations

5.11.1 Bookmarks
When working with large drawings you may need to visit some parts of the drawing more frequently than others. In
these cases you can take advantage of the MyDraw's bookmark feature. Bookmarks store a location and a zoom factor
and can be used to quickly move the viewport to a given location and zoom in or out the diagram.

Creating and navigating through bookmarks
To create a bookmark open the View tab of the ribbon and click the Add button from the Bookmarks ribbon group:

After you click the Add button, enter a name for the new bookmark and click OK. MyDraw will then store the current
position in the drawing and the current zoom factor and create a bookmark with the given name. To navigate through
the bookmarks for the active page select a bookmark from the combo box or use the Previous Bookmark and
the Next Bookmark buttons. MyDraw will then start an animation and move to the selected bookmark.

Note that bookmarks are stored on a per page basis. The ribbon shows the bookmarks for the active page.

Editing bookmarks
To edit individual bookmarks or the whole bookmarks collection of the active page, click the Edit button. The
following dialog will open:

In this dialog you can use the buttons from the toolbar below the list box on the left to add, remove or reorder the
bookmarks. If you select a bookmark from the list box, you will see its properties on the right and you can change

MyDraw User Guide 79

©2020 Nevron Software. All Rights Reserved.



them if you want.

The Settings tab lets you change the transition duration for moving to the selected bookmark in milliseconds (ms). It
is by default set to 2000 ms, which is equal to 2 seconds.

Finally click OK to apply the changes or Cancel to cancel them.

5.11.2 Presentations
MyDraw can make presentations by switching to presentation mode. A MyDraw presentation lets you show each page
and bookmark of your drawing with animated transitions between them.

To begin a presentation on the current drawing click the View Presentation button in the status bar:

 

Alternatively, you can start a presentation by opening the View ribbon tab and then clicking the View Presentation
button. Either way, the presentation window will open and show your drawing in full screen.

At the bottom of the presentation window you will see the following widgets:

Timeline - shows the timeline of the presentation. All pages and bookmarks of your drawing are shown as
points on this timeline. The timeline is filled from its beginning to the currently shown point to indicate the
progress of the presentation. You can click any of the points or navigate using the following keyboard keys:

Spacebar - navigates to the next point on the timeline.
Left arrow - navigates to the previous point on the timeline.
Right arrow - navigates to the next point on the timeline.
Escape - closes the presentation window.

Page Navigator - switches between the pages of your drawing. Visible only if your drawing has more than one
page.
Bookmark Navigator - navigates through the bookmarks in the current page. Visible only if the current page
has any bookmarks. For more information about bookmarks check out the Bookmarks topic.
Zoom Slider - zooms in or out the current page.
Close button - closes the presentation view and returns to the MyDraw application window. You can also press
the Escape key from the keyboard to close the presentation view.

5.12 Mail Merge

5.12.1 Mail Merge
MyDraw makes it easy to perform mail merge in order to create many documents out of one template document. You
can either save the result of the mail merge to disk as different files or you can send the files by e-mail to different
recipients. The mail merge commands of MyDraw are placed in the Mailings ribbon tab:
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Configuring Mail Merge
You should start by selecting a mail merge source, for example an Excel file. To do this, open the Mailings ribbon tab
and click the Select Recipients button. In the wizard that opens follow the steps to select and configure a mail merge
data source.

After you have selected a mail merge data source you can start inserting mail merge fields into the texts of the
shapes. Using the Preview Mail Merge button you can see the results of the mail merge for the current record. To
see the mail merge result for a different record, simply use the mail merge record navigator that is placed below the
Preview Mail Merge button.

Merge and Save
The Merge & Save ribbon button executes the mail merge operation, creates a set of resulting documents and saves
them to disk in a file format of your choice. When you click this button a save file dialog opens and you can select the
template file name to save to, for example "MailMerge.pdf". Then all generated documents will be saved in the folder
of this file with a suffix showing the one-based record index of the resulting document - "MailMerge_1.pdf",
"MailMerge_2.pdf", etc.

Merge and Send
The Merge & Send ribbon button executes the mail merge operation, creates a set of resulting documents and sends
them as attached files to e-mail messages to a set of recipients. When you click this button, a dialog for configuring e-
mail send options opens:
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Note that the mandatory fields are marked with an asterisk symbol. When you enter your e-mail sending options,
select the mail merge field that contains the e-mail addresses of the recipients and click the OK button. MyDraw will
then start generating and sending the e-mail messages displaying a progress dialog while they are being sent.

5.13 Data Import

5.13.1 Generating Org Charts from Excel
MyDraw provides support for importing Organizational Charts from Excel. To import an Org Chart in MyDraw,
click File -> Import -> Organizational Chart. In the Organizational Chart Editor window that opens, select the org
chart, then the sheet within the org chart. The Id box is the row which uniquely identifies the person, as the Name box
is the name of the person. The Reports to box is the row which identifies the person's manager. Fill in the other
optional information if necessary, and check the Load Images box if you wish to load the images from the excel
file. Also you will need to map the name of the images with some of the columns in the data source file, for example
Employee Name. When you are ready, click OK.
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Here is an example of an Excel Org data chart:

 

5.13.2 Generating Flowcharts from Excel
 MyDraw provides support for importing flowcharts from Excel. To import a flowchat into MyDraw, click File ->
Import -> Flowchart. In the Open Excel Data Template window that opens, select the excel flowchart, then
the layout direction. The Sheet Name specifies the value of the sheet property. When you are ready, click OK.
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Each row of the following table represents a single flowchart shape.

To be able to load the data successfully, the Excel table must have the follwoing columns:

Process Step ID - An unique integer value which identifies the shape.

Process Step Description - A string which will be shown as a text in the shape.

Next Step ID - The ID value of the next shape in the sequence. If there is a branching each ID must be separated by
comma. This field is not mandatory.

Connector label - The text that will be displayed on the connector that connect current shape with the next one. If
there is a branching each text must be separated by comma.

Shape Type - String which represents the shape type. The names of the most used shapes are shown in the table
below. However you can put the name of all flowcharting shapes which are present in Flowcharting Shapes library.

Shape name Shape

"Start" / "Stop"

"Process"

"Subprocess"

"Document"
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"Decision"

5.14 Family Trees

5.14.1 Family Tree Diagrams
MyDraw lets you create family tree diagrams with ease. You can either start with one of the included family tree
diagram templates or create a new blank drawing and drop a family tree person shape from the family tree shapes
library.

Family Tree Shapes and Events
MyDraw comes with two special shapes that you can use to create family tree diagrams:

Person shape - rectangular shape that consists of 3 parts: photo (or gender based icon if photo is not
specified), name and dates. The person shapes are filled differently based on the gender of the person:

Blue - male
Orange - female

Family shape - circular shape that is connected to the spouses and their children and contains the year of the
spouses marriage and the year of the divorce if they are divorced. When you place and hold the mouse pointer
over a family shape, a tooltip with the exact date and place of the marriage and the divorce (if any) will be
shown. The family shapes are filled differently based on the status of the family:

Green - the spouses live together without being married
Blue - the spouses are married. The year of the marriage (if known) is shown in the center of the shape.
For example: "2009".
Red - the spouses are divorced. The years of the marriage and the divorce (if known) are shown with a
dash in the center of the shape, for example: "2009-2015".

Family tree events are entities that include a date and a place. They are used in family tree shapes to describe events,
for example birth and death for a person shape and marriage and divorce for a family shape.

Editing Shapes and Events
To edit a person or a family shape double click it and a dialog for editing its data will open. For a person shape you
can edit the person's names, photo, gender, birth and death events and for a family shape you can edit its marriage
and divorce events. Alternatively you can edit a person shape by right clicking it and selecting Edit Person from the
context menu.

By default events are not set and are labeled as Automatic in the dialog. To create a new event click the Automatic
button next to the event, select Family Tree Event for type and set the date and place of the event. If you want to
delete an event, click it and select Automatic or None for event type.

Adding Shapes
To add a spouse to a person shape, right click it and select the Add Spouse menu option. A spouse with be added
next to the selected person shape and a family shape will be placed below the spouses and connected to each of
them. You can then click the family shape to add children to the family.

In case you need to build your tree in the other direction, too (i.e. from children to parents) you can right click a
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person shape and select the Add Parents menu option from the context menu.

Arranging Family Tree Diagrams
Family tree diagrams are automatically arranged when you add a person shape through the context menu options,
but you can also layout them by executing the Family Graph Layout from the Layout Shapes dialog (it can be
launched from the Arrange ribbon tab). In this way you can configure the different layout options, including the
layout direction (e.g. "left to right", "top to bottom", etc.).

The following image shows a part of the family tree diagram of the US President Abraham Lincoln, created with
MyDraw:

GEDCOM Import and Export
MyDraw comes with full support for importing and exporting family tree diagrams to the popular Genealogical Data
Communication (GEDCOM) format. For more information check out the GEDCOM Import and Export topic.

5.14.2 Arranging Family Tree Diagrams
Family tree diagrams are automatically arranged when you add a person shape through the context menu options,
but you can also lay them out by executing the Family Graph Layout from the Layout Shapes dialog (launched from
the Arrange ribbon tab). In this way you can configure the different layout options, including the layout direction (e.g.
"left to right", "top to bottom", etc.).

The following image shows a part of the family tree diagram of the US President Abraham Lincoln with an automatic
layout, created with MyDraw:
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6 File Formats

6.1 File Formats Overview
Drawings
MyDraw can load and save drawings in many popular file formats. The following table illustrates the drawing file
formats currently supported by MyDraw and whether they can be used to load drawings, to save drawings or both.

File Format Load Save Notes

MyDraw XML
Drawing (NDX)

✔ ✔ The default native MyDraw format. Preserves all formatting and information.

MyDraw Binary
Drawing (NDB)

✔ ✔ Native MyDraw format. Preserves all formatting and information.

MyDraw XML
Drawing
Template
(NDTX)

✔ ✔ Native MyDraw format. Preserves all formatting and information. Used as a template
for new documents.

Visio Drawing
(VSDX)

✔ ✔ The drawing format used in Visio 2013 and newer.

Visio 2003-
2010 Drawing
(VSD)

✔ ✘ The drawing format used in Visio 2010 and older. MyDraw does not support drawings
created with Visio 2002 and older. 

Visio 2003-
2010 XML
Drawing (VDX)

✔ ✔ A XML based drawing format used in Visio 2010 and older. MyDraw does not support
drawings created with Visio 2002 and older.

AutoCAD
Drawing
Interchange
(DXF)

✔ ✔ Imports the AutoCAD drawing in a shape with the default AutoCAD dark gray
background.
Exports only the active page of the drawing.

Enhanced
Metafile (EMF
and EMF+)

✔ ✔ Exports only the active page of the drawing.

ESRI Shapefile
(SHP)

✔ ✘ A popular file format that contains vector map data commonly used by geographic
information system (GIS) software.

Genealogical
Data
Communication
(GEDCOM)

✔ ✔ Creates an empty file if no family tree shapes are present in the diagram. For more
information check out the Family Tree Diagrams topic.

Portable
Document
Format (PDF)

✘ ✔ Exports only the active page of the drawing.

Raster Images ✘ ✔ Diagrams cannot be loaded from raster images, but raster images can be inserted in a
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(BMP, PNG,
JPG, GIF, TIFF)

diagram by opening the Insert ribbon tab and clicking the Image button or by
configuring the fill style of a geometry to be of type image fill. Save exports only the
active page of the drawing.

Scalable Vector
Graphics (SVG)

✘ ✔ Exports only the active page of the drawing.

Web Page
(HTML)

✘ ✔ Exports the whole diagram to a single HTML page. If the diagram has multiple pages,
tab navigation is added to the resulting HTML page.

Libraries (Stencils)
MyDraw can load and save libraries (stencils) in many popular file formats. The following table illustrates the library
file formats currently supported by MyDraw and whether they can be used to load libraries, to save libraries or both.

File Format Load Save Notes

MyDraw XML Library
(NLX)

✔ ✔ The default native MyDraw library format. Preserves all formatting and
information.

MyDraw Binary
Library (NLB)

✔ ✔ Native MyDraw library format. Preserves all formatting and information..

Visio Stencil (VSSX) ✔ ✔ The library (stencil) format used in Visio 2013 and newer.

Visio 2003-2010
Stencil (VSS)

✔ ✘ The library (stencil) format used in Visio 2010 and older. MyDraw does not
support stencils created with Visio 2002 and older.

Visio 2003-2010 Xml
Stencil (VSX)

✔ ✔ A XML based library (stencil) format used in Visio 2010 and older. MyDraw does
not support stencils created with Visio 2002 and older.
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6.2 Visio Drawing
MyDraw provides support for both importing and exporting drawings to the most popular diagramming document
format - Visio Drawing (VSDX) format. Import of drawings in the older Visio 2003-2010 drawing format (VSD) is also
supported.

Visio Drawing Import
To import a Visio Drawing in MyDraw:

1. Click the File menu
2. Click Import
3. Click Visio Drawing
4. Select the Visio drawing you want to open and click the Open button

MyDraw will then import the selected Visio Drawing.

Alternatively you can click File -> Open and open the desired Visio Drawing.

If a given Visio Drawing does not open properly in MyDraw, please send it to us at support@mydraw.com. This will
help us analyze it and fix any issues with it for the next version of MyDraw.

MyDraw can open only drawings created with Visio 2003 and newer. Drawings created by Visio 2002

and older are not supported.

Visio Drawing Export
To export a MyDraw drawing to a Visio Drawing:

1. Click the File menu
2. Click Export
3. Click Visio Drawing
4. Enter the file name of the Visio Drawing you want to save to and click the Save button

MyDraw will then export the currently opened drawing as Visio Drawing.

Alternatively you can click File -> Save As, select "Visio Drawing" for file type and save your drawing to a Visio
Drawing format.

If a given drawing does not export properly to Visio Drawing, please save it as a Nevron XML Drawing and send it to
us at support@mydraw.com. This will help us analyze it and fix any issues with it for the next version of MyDraw.

Importing and exporting of drawings in the older Visio format "Visio 2003-2010 Drawing (VSD)" under Mac
requires an active Internet connection. Under Windows there isn't such requirement.
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6.3 AutoCAD Drawing Interchange
AutoCAD Import
MyDraw lets you import AutoCAD Drawings in DXF format in two ways:

As an image - to import an AutoCAD Drawing Interchange (DXF) file as an image open the Insert ribbon tab of
MyDraw and click Image.
As a document - to open an AutoCAD Drawing Interchange (DXF) file as a new document click File -> Import ->
AutoCAD Drawing Interchange (DXF).

In both cases the AutoCAD drawing will be imported in the image block of a shape with darjk gray background - the default
background of AutoCAD. If you want to change the background color of the shape, select the shape, click the drop down of
the fill button (the one with a bucket) in the "Shape Style" ribbon group and select a new color or "None" if you do not want
the shape with the imported AutoCAD Drawing to have a background:

AutoCAD Export
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MyDraw lets you easily export the active page of any drawing to AutoCAD Drawing Interchange format (DXF). You can do so
in two ways:

Click File -> Export -> AutoCAD Drawing Interchange (DXF). The file dialog shown below will open. In it you can
configure whether the whole active page of your drawing or only a specific part of it should be exported. When ready,
click the Save to File button to save the selected area to AutoCAD Drawing Interchange (DXF) format.

Click File -> Save As and select "AutoCAD Drawing Interchange (*.dxf)" for file format. Then select the file to save
your drawing to and click Save. A dialog similar to the one above will open. Configure whether you want the whole
active page or only a part of it to be exported and click OK.
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6.4 Raster Image
MyDraw supports exporting of drawing to a set of popular raster image formats like bitmap (BMP), PNG, JPEG and
TIFF. To export a drawing to a raster image, click File -> Export -> Raster Image... The following dialog will open:

In this dialog you can specify whether the whole page or only a part of it should be exported as well as the resolution
of the generated image in dots per inch. Note that the part of the active page that is going to be exported to image
will be highlighted, so that you can easily see what's going to be exported and what's not. When ready, click the Save
to File button to save the image to a file or use the Copy To Clipboard button to copy it to system's clipboard, so
that you can paste it easily in other programs for further processing.
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6.5 Enhanced Metafile (EMF)
MyDraw lets you easily export the active page of any drawing to Enhanced Metafile vector image format (EMF). You can do
so in two ways:

Click File -> Export -> Enhanced Metafile (EMF). The file dialog shown below will open. In it you can configure
whether the whole active page of your drawing or only a specific part of it should be exported. When ready, click the
Save to File button to save the selected area to Enhanced Metafile (EMF) format.

Click File -> Save As and select "Enhanced Metafile (*.emf)" for file format. Then select the file to save your drawing
to and click Save. A dialog similar to the one above will open. Configure whether you want the whole active page or
only a part of it to be exported and click OK.
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6.6 Scalable Vector Graphics (SVG)
MyDraw lets you easily export the active page of any drawing to Scalable Vector Graphics vector image format (SVG). You
can do so in two ways:

Click File -> Export -> Scalable Vector Graphics (SVG). The file dialog shown below will open. In it you can
configure whether the whole active page of your drawing or only a specific part of it should be exported. When ready,
click the Save to File button to save the selected area to Scalable Vector Graphics (SVG) format.

Click File -> Save As and select "Scalable Vector Graphics (*.svg)" for file format. Then select the file to save your
drawing to and click Save. A dialog similar to the one above will open. Configure whether you want the whole active
page or only a part of it to be exported and click OK.
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6.7 Web Page
MyDraw makes it easy to export any drawing to an HTML Web Page. To do so, click File -> Export -> Web Page.

If the drawing document contains multiple pages, MyDraw will automatically embed tab navigation in the resulting
HTML web page and each tab page in the HTML document will show a page from your original drawing. Pages are
exported in Scalable Vector Graphics (SVG) format and are directly embedded in the resulting web page. This makes it
very easy to disribute or share, because you only have to copy/send a single HTML file.

Shape hyperlinks also get exported to HTML, so you links to another page or an URL will work fine in the generated
HTML file.

6.8 Genealogical Data Communication
MyDraw comes with full support for importing and exporting family tree diagrams to the popular Genealogical Data
Communication (GEDCOM) format. GEDCOM is the standard for exchanging genealogical data (like family trees)
between different genealogical software. It is commonly used for creating family tree diagrams.

GEDCOM Import
To import a GEDCOM file in MyDraw:

1. Click the File menu
2. Click Import
3. Click Family Tree
4. Select the GEDCOM file you want to open and click the Open button

GEDCOM Export
To export a GEDCOM file in MyDraw:

1. Click the File menu
2. Click Exoprt
3. Click Family Tree
4. Select the file you want to save to and click the Save button

Note that when exporting a diagram to GEDCOM format only the information contained in family tree shapes
will be exported. You will loose all other shapes and all formating and positioning. If you want to preserve the
diagram with all of its shapes and formatting then please also save it in one of the native MyDraw formats -
NDX or NDB.
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6.9 ESRI Shapefile
MyDraw provides support for importing of geographical map data from the popular ESRI shapefile format (".shp"). To
import a map in MyDraw, click File -> Import -> Map. In the open file dialog that opens, select the shapefile to
import and click Open.

If the shapefile you want to open has an accompanying data file (i.e. a file with the same name, but with a different
extension - ".dbf"), the following dialog will open:

 

This dialog lets you configure how the data from the DBF file should be used when importing the map in MyDraw.

The "Name and Text" group box lets you select the columns that should provide the names and the texts of the
imported shapes, as well at in what zoom range the shapes and their text should be visible.

The "Fill" group box lets you select a column, whose values should be used for filling. The filling is defined by the
selected number of colors, begin and end color. MyDraw will automatically create color shades starting from the
selected begin color and ending at the end color. This lets you easily color a map by a data column defined in the
data file. For example, you can color the countries in a world map based on their population. The countries with small
population - white, the ones with more population - light green, those with large population - green and the countries
with most population - dark green.

6.10 PDF
MyDraw supports native export of any drawing to PDF. To do so click File -> Export -> PDF. The following dialog will
open:
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The PDF export dialog lets you configure the page size, orientation and page margins and shows a preview of the
export. You can also specify the print layout that determines the zoom mode of the diagram. If the paging mode is set
to "Fit To Pages", you can specify on how many pages the diagram should be spread over. For example if you want
the diagram to fit on 1 page, set page columns and page rows to 1. If you want the diagram to span on 6 pages, set
the page columns to 3 and page rows to 2, and so on. When ready, click the Export to PDF button to export the
diagram to a PDF file.
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7 Troubleshooting
This documentation topic gives suggestions that may help you fix issues with MyDraw.

Windows Issues
MyDraw for Windows can load and apply some settings before the software is launched. These settings should be
defined in a file LaunchSettings.ini placed in the folder %appdata%\MyDraw. You can directly copy and paste this
folder path into the address bar of Windows Explorer and press Enter from the keyboard. Then right click into an
empty area of the folder and select New -> Text Document to create a new text document. Rename it to
LaunchSettings.ini and open it with a text editor of your choice (for example Notepad).

The settings should be defined by specifying key/value pairs separated by an equals ("=") sign. The following settings
are currently supported:

EnableGpuRendering=true/false - enables or disables hardware graphics acceleration. By default set to true.
Set it to false to disable hardware graphics acceleration if MyDraw fails to start or you notice unusual graphical
artifacts or glitches.

The following is a sample LaunchSettings.ini file that disables hardware graphics acceleration:

LaunchSettings.ini

EnableGpuRendering=false

To download the file above click here.
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