
1 Introduction

MyDraw is a powerful, yet easy to use diagram software. It provides a large selection of shapes, formula based
engine like in Microsoft Visio, a lot of automatic layout algorithms and many other features. The following list
outlines the main features of MyDraw in more details:

UI
Library browser
Pan and zoom view
Drawing view with different view modes
Rulers
Guidelines
Predefined UI themes:

Windows 8
Windows 7 Aero
Windows XP
Mac OS El Capitan
Mac OS Lion
Nevron Light
Several windows classic themes

A "New Drawing" dialog with a large set of drawing templates to choose from
Document

 Multiple pages
Large number of predefined shapes
Grouping and ungrouping of shapes
1D and 2D barcodes
Measurement units and scaling
Formulas

Interaction
Rotation, scaling and moving of shapes and groups
Many tools such as pointer tool, rectangle tool, ellipse tool, geometry tool, pan tool, etc.
Snap and glue
Spacing and positioning of shapes
Automatic layouts and routing
Shape protections
In place editing and formatting of texts
Tooltips and clickable hyperlinks for shapes and groups

Printing
Print dialog with settings for page size, margins and layout mode
Ability to exclude certain shapes and groups from printing

Formats
Native MyDraw XML and binary based formats
Native MyDraw XML template format
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Visio Drawing (VSDX) import and export
Import of map data from ESRI shapefiles (SHP)
Import and export of genealogical data in GEDCOM format (GED), for example: family trees
Raster image export: bitmap (BMP), JPEG, PNG
Vector image export: SVG
PDF export
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2 Licensing

Online Activation
Activate MyDraw Product Licenses

If you have purchased a license for MyDraw, you can activate it as follows:

1. Launch MyDraw and create a new blank drawing
2. Click the File menu and then About
3. Enter the username (e-mail) and password of your MyDraw account
4. Click the Activate button to activate the software
5. Restart MyDraw for changes to take effect

Revoke or Transfer MyDraw Licenses

At any time you can transfer you license to another computer by deactivating it first on your current computer
and then activating the license on the new computer following the above procedure. To deactivate your license on
your current computer, do the following:

1. Launch MyDraw and create a new blank drawing
2. Click the File menu and then About
3. Enter the username (e-mail) and password of your MyDraw account
4. Click the Deactivate button to deactivate the software
5. Restart MyDraw for changes to take effect

After deactivating a license on one computer, you will be able to activate it on another computer.

Local Activation
If the computer you have installed MyDraw on doesn't have an Internet connection, you can activate MyDraw
locally by doing the following:

1. Click the File menu in MyDraw's ribbon and then click About.
2. Click the Local License button
3. Click the License button and you'll be redirected to the purchase page from where you can purchase a

license.
4. Use the Copy Machine Id button of the About dialog to copy your machine ID. Then paste it in an email,

send it to sales@mydraw.com and we'll respond with a license key. 

After you receive a registration code click File -> About -> Local License and in the dialog that opens, perform
these steps: 

1. Press the Add... key.
2. Enter (or copy / paste) the license key you obtained from Nevron.
3. Press OK.
4. Press Close. 

That's it, you have successfully applied the license key to MyDraw.
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3 Version History

Version 2.3.1 (May 2018)

Visio export improvements
UI improvements and bug fixes

Version 2.3.0 (May 2018)

All non-native file formats moved to Import and Export menu items
Visio import and export improvements
Import of flowcharts from Excel data
UI improvements and bug fixes

Version 2.2.0 (April 2018)

Bookmarks of drawing view position and zoom level
Presentation mode
Check for updates and auto update
Tagged Image File Format (TIFF)

Version 2.1.1 (March 2018)

Bug fixes and stability improvements

Version 2.1.0 (March 2018)

Improved print preview and printing
Support for connector splitting when dropping a 2D shape on a connector
Drawing documents now store which libraries were opened when they were last saved
Visio export improvements
Added German translation of the user interface

Version 2.0.3 (February 2018)

Contextual help in property editors
Improved support for high resolution displays (WQHD, 4K Ultra HD, etc.)
Improved support for multi-monitor environments

Version 2.0.2 (January 2018)

Support for Windows XP (.NET Framework 3.5 should be installed)
Visio import improvements
UI improvements and bug fixes

Version 2.0.1 (December 2017)

Mini toolbar added to context menu
Bug fixes

Version 2.0.0 (November 2017)

New file formats:
AutoCAD (DXF) export
Visio 2003-2010 Drawings (VSD, VDX)
Visio Stencils (VSSX)
Visio 2003-2010 Stencils (VSS, VSX)
Enhanced Metafiles (EMF)
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New shape libraries
New drawing templates
Autosave
Multi-monitor support
UI improvements and bug fixes

Version 1.0.1 (June 2017)

UI, stability and performance improvements
Bug fixes

Version 1.0.0 (May 2017)

First version of MyDraw
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4 User Interface

4.1 UI Overview

The following image shows the main parts of MyDraw's user interface (UI):

Drawing View - this is the area in which you can create your diagrams
Library Browser - lets you quickly insert shapes into the drawing view using drag and drop
Pan and Zoom View - presents a small preview of the drawing document and can be used to quickly
move to another area of the document
Ribbon - contains a set of buttons, menus, combo boxes and other command controls organized logically
in groups and tabs that let you manipulate the diagram, add, arrange and style shapes and so on
Ribbon Search Box - lets you quckly search for and execute a command
Page Navigator - lets you add more pages to your drawing document, name, delete or edit them and
switch between them
Zoom Slider - lets you quickly zoom in and out the drawing view
Status Bar - shows useful information about the current selection and the mouse pointer location
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4.2 New Drawing Dialog

The New Drawing dialog is shown when you start MyDraw and lets you quickly create a blank new drawing or create
a drawing based on a drawing template. 

 

The dialog consists of two main parts:

Sidebar
The sidebar is placed at the left side of the New Drawing dialog and lets you open one of the recently opened
drawings. You can also pin/unpin and remove drawings from the recent documents list. Below the list of recent
documents you will find an Open button that lets you browse to a drawing of your choice and open it in MyDraw.

Main Content
The main content of the New Drawing dialog lets you create a blank new drawing or create a drawing based on a
template and consists of the following widgets:

Template Search Box - lets you search for a drawing template by name. Simply start typing in the
search box and you will see a list of matching templates. To open any the templates in the list, click it
with the left mouse button or select it with the arrow keys and press Enter.
Breadcrumb - lets you go back to a parent category in the list of templates.
Template Picker - lets you select a drawing template to open in MyDraw. At the root level of the
template selector you can also select the "Blank Drawing" option to create a blank new drawing or the
"New from Existing..." option to create a new drawing based on an exsiting one. The other items in the
template picker are template categores. If you click any of them, the category will open and you will see
its templates and sub categories.
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4.3 Drawing View

The drawing view is the area in which you create your diagrams. To help you position shapes more precisely it shows a
grid and rulers by default. The view also aids you by providing snapping behavior to grids, rulers and guidelines.

Guidelines are vertical or horizontal lines you can use to align shapes to. To create a guideline simply drag the
horizontal or the vertical ruler towards the drawing view. If you want to center the guideline in the page, right click it
and select Center in Page.

You can show and hide different elements of the drawing view as well as to control its zooming mode through the View
tab page of MyDraw's ribbon:

Show Ribbon Group
The Show ribbon group lets you toggle the visibility of the different elements such as grid, guidelines, ports,
rulers, etc. The following image illustrates the elements you can show or hide using the check boxes of the Show
ribbon group:
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You can use the Splitter collapse buttons to collapse and expand the splitter pane and the library. MyDraw saves
these settings, so the splitter positions you set will be applied again the next time you start MyDraw.

Zoom Ribbon Group
The Zoom ribbon group lets you change the zoom mode of the drawing view to one of the following:

Normal - in this mode the drawing view zoom factor is not automatically calculated
Fit to Page - the drawing view is automatically zoomed in or our so that a whole page is shown in the
available area
Fit to Width - the drawing view is zoomed so that the whole width of the current page is visible
Fit to Height - the drawing view is zoomed so that the whole height if the current page is visible

You can use the Zoom In and Zoom Out buttons to zoom in and out the drawing view respectively. Alternatively
you can use the mouse wheel while holding with the Ctrl keyboard button or the following keyboard shortcuts:

Zoom In - Ctrl + "+"
Zoom Out - Ctrl + "-"
Zoom to 100% - Ctrl + "0"

The keyboard shortcuts for zooming are identical to those of most modern web browsers, which makes them easy to
remember.
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Settings Ribbon Group
The Settings ribbon group contains 5 buttons. When clicked each of them displays a dialog for editing the
properties of the object it's associated with:

Page - edits the properties of the active page. For more information check out the Page Settings topic.
Grid and Rulers - edits the properties of the grid and the rulers.
Routing - configures the routing manager and the routing settings.
Line Jumps - edits the line jumps settings.
Print Layout - edits the print layout settings.
Drawing Settings - configures the whole drawing.
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4.4 Library Browser

The library browser is a navigation bar which contains several sets of shapes, called libraries. You can drag and drop
any shape from the library browser to the drawing view in order to add shapes to the diagram and vice versa - you
can drag and drop shapes from the drawing view area to the currently selected library to add them to that library to
reuse them later on. Once you’ve dropped the desired shape in the drawing view of MyDraw you can then customize
it using the ribbon, or the context menu. To show the shapes of another library simply click its icon in the library
browser.

Library Browser Parts
The following image illustrates the parts of MyDraw's library browser.
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The numbered parts are the following:

1. Predefined Libraries button - lets you quickly open and close one or more of the predefined libraries
2. New Library button - lets you create a library of your own. When you click this button, a dialog in which

you can enter the name and the author of the new library will open. When ready click OK and a new
library will be added to the library browser. You can drag and drop any shape from the drawing view to
this new library view and it will be added to it. You can use buttons 3 and 4 in the toolbar of the library
browser to load and save libraries.

3. Open Library button - opens an existing library from file.
4. Save Library button - saves the currently selected library to file.
5. Close Library button - closes the currently selected library.
6. Icons View button - switches the library browser to icons view.
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7. List View button - switches the library browser to list view.
8. Thumbnails View button- switches the library browser to thumbnails view.
9. Default Display Order button - shows the library shapes in the order they are defined in the library.

10. Text Ascending Display Order button - sorts the library shapes by their text in ascending order.
11. Text Descending Display Order button - sorts the library shapes by their text in descending order.
12. View Libraries button - switches the library browser to library view mode.
13. Library Search button - switches the library browser to library search mode. In this mode you can enter

one or more characters and the library browser will show you all shapes that match them. You can also
configure the type of the search using the "Match Mode" combo box and the "Case Sensitive" check box.

14. Library View - contains the shapes of the currently selected library.
15. Libraries toolbar - contains the currently opened libraries. The names of the the libraries are shown as a

tooltip when you hold the mouse cursor for a short time over the icon of a library.
16. Selected Library - indicates the currently selected library.

Predefined Libraries

Most of the drawing templates come with several opened predefined libraries. If you want to open or close more
of the predefined libraries, click the Predefined Libraries button (item 1 in the "Library Browser Parts"
section). A dialog with all available predefined libraries will open (see the screenshot on the left).

Check the predefined libraries you want to be opened, uncheck the ones you want to be closed and when ready
click the OK button.

Search Shapes
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The Library Search button (item 13 in the "Library Browser Parts" section) switches the library browser to
library search mode. Enter several characters in the "Look for" text box and MyDraw will show you all shapes
from the currently opened libraries whose names contain these characters. If you want the check to be case
sensitive, check the Case Sensitive check box.

You can also choose between one of the following matching modes:

Contains - matches all shapes whose name contains the entered characters
Starts with - matches all shapes whose name starts with the entered characters
Word Starts with - matches all shapes whose name contains a word that starts with the entered
characters
Ends with - matches all shapes whose name ends with the entered characters
Word Ends with - matches all shapes whose name contains a word that ends with the entered characters
Contains Any Word - matches all shapes whose name contains a word starting with one of the words of
a given substring and orders the matched shapes by the number of matched words
Contains All Words - matches all shapes whose name contains all of the entered words
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4.5 Pan and Zoom View

You can use the Pan and Zoom view to jump to a different location of the drawing view or to zoom it in or out. To
move across the drawing view simply drag the pan and zoom view rectangle with the left mouse button. If you resize
this rectangle using the tracers at its corners, then the drawing view will zoom in or out.

The following image demonstrates how to use the Pan and Zoom View to set the visible area of the drawing view.
Note how the visible area of the drawing view matches exactly the red rectangle of the Pan and Zoom View.
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4.6 Page Navigator

The page navigator lets you add, remove, rename and edit pages to your diagram documents and navigate through
these pages.

To add a page, click the Add button. You can then click on the button associated with a given page to navigate to it.
The button All shows a menu with all pages of the current document, so you can easily switch to the desired page.

To rename a page, right click it and select Rename from the context menu.

To delete a page, right click it and select Delete from the context menu.

To create a duplicate (i.e. an exact clone) of a page, right click it and select Duplicate from the context menu.

To edit the properties of a page, right click it and select Page Properties from the context menu.

The button All shows a menu with all pages of the current document, so you can easily switch to the desired page.
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4.7 Ribbon

Home Tab Page
Action Tab Page
Arrange Tab Page
Insert Tab Page
Review Tab Page
Mailings Tab Page
View Tab Page
Application Menu

Each command item in the ribbon has a tooltip, which contains information about the command and its
keyboard shortcut (if any), so when in doubt about what a given command does, simply move the mouse pointer
over it and wait a second for the tooltip to show up.

Home Tab Page
The Home tab page is the default page of the diagram ribbon.

As the image above shows the Home tab page is organized into the following ribbon groups:

Clipboard - lets you cut or copy the currently selected shapes. When there are compatible objects in the
clipboard you can also use the Paste button to paste them in your diagram.
Font - lets you control the font, size and appearance of the text of the currently selected shape.
Paragraph - lets you specify the text alignment of the currently selected shape.
Geometry Format - lets you control the fill, stroke, shadow and corner rounding of the currently
selected shape. For 1D shape (i.e. connectors) you can also specify the begin and end arrowhead styles.
Tools - contains a set of tools that you can activate in order to create custom shapes, edit the geometry of
a shape, insert text, pan the diagram or simply to go back to the default tool as shown on the above image -
the pointer tool.
Editing - lets you undo/redo the recently made changes to your diagram, as well as to select all shapes, all
1D shapes or all 2D shapes.
Search - contains buttons for finding and replacing texts in shapes

Action Tab Page
The Action tab page lets you manipulate the currently selected shape/shapes.

The Action tab page consists of the following ribbon groups:

Group - lets you group and ungroup a set of shapes.
Rotate - lets you flip or rotate a shape.
Compose - lets you create a complex geometry shape by performing a geometry operation to a set of
shapes.
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Arrange Tab Page
The Arrange tab page lets you position, size and align your shapes:

The Arrange tab page consists of the following ribbon groups:

Align - lets you align two or more shapes.
Resize - lets you size one or more shapes to another shape.
Position - lets you position a shape within the page.
Z-order - lets you bring a shape above or below other shapes.
Spacing - lets you configure the spacing between two or more shapes.
Grid - lets you align or size shapes to grid.
Snap - lets you configure the snapping behavior of MyDraw.
Layout - contains a Layout Shapes button, which when clicked opens a dialog for selecting, configuring
and applying an automatic layout to the selected or all shapes of your diagram.

Insert Tab Page
The Insert tab page lets you insert an object into the document.

The Insert tab page currently has the following ribbon groups:

Illustrations - lets you easily insert an image or a 1D/2D barcode to your diagram. If you insert a
barcode, you can then right click it to modify its properties.
Symbols - lets you insert special text characters and symbols into the text block of a shape
Text - lets you insert hyperlinks and different text fields into the text block of a shape

Review Tab Page
The Review tab page lets you perform a spell check of the texts of a drawing.

The Review tab page currently has the following ribbon buttons:

Spell Check - a toggle button that enables or disables the spell checking for the whole document.
Symbols - lets you select the spell check dictionary to use. You can use any of the included spell check
dictionaries or load a different spell check dictionary using the Browse button. MyDraw is compatible
with Open Office spell check dictionaries.
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Mailings Tab Page
The Mailings tab page lets you configure and perform a mail merge operation.

For more information, check out the Mail Merge topic.

View Tab Page
The View tab page lets you control the visibility, the behavior and the settings of various elements of the drawing
view.

For more information, check out the Drawing View topic.

Application Menu
The application menu is shown when you click on File. It contains menu items for saving the diagram or loading a
diagram from a file, for printing and export and so on. It also contains the menu item for showing the About dialog
and the button that shows the Options dialog, which you can use to switch the current UI theme, or switch to
traditional command bar UI. It also lets you switch the user interface to another language. The application menu
also contains a New menu option that opens the New Drawing Dialog.

The right side of the application menu shows the recently opened/saved documents with the ability to pin the ones
you find more important.
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5 Basic Tasks

5.1 Working with Drawings

This topic explains how to perform the following operations:

Create a new drawing
Open a drawing
Save a drawing

Create a new drawing
MyDraw by default starts with the New Drawing dialog, which lets you quickly create a new blank drawing or a
drawing based on a drawing template. At any time you can also click File and then New (or press Ctrl+N) to
start a new diagram.

Open a drawing
To open a drawing click File and then Open or press Ctrl+O from the keyboard. An "Open File" dialog will open
in which you can select the file you want to open. You can also drag and drop a compatible file format to the
drawing view of MyDraw and it will open.

For your convenience MyDraw also maintains a list of the recently used drawing documents at the right side of
the application menu. You can click any of the documents there to open it. You can also use the pin buttons next
to each recent document to pin it to/unpin it from the recent documents menu.

For a full list of the file formats supported by MyDraw, check out the File Formats Overview documentation topic.

Save a drawing
To save a drawing click File and then Save or press Ctrl+S from the keyboard. When you save your document
for the first time in this way, a Save File dialog will open in which you can specify the name and the type of the file
MyDraw should save your diagram to. If you want to save your drawing as a template, select the MyDraw XML
Drawing Template format.

The Save As menu item always shows the Save File dialog and lets you choose a file name and type. The Save As
menu item also provides a submenu of commonly used file types that lets you quickly choose a file format to save
your document in.

For a full list of the file formats supported by MyDraw, check out the File Formats Overview documentation topic.

Note that if you want to preserve all features and formatting of your drawings, you should always save them
in one of the MyDraw native formats (NDX or NDB). If you need a drawing in another format, you can then
save it to another format, too, but it is recommended that you awlays save it to a native MyDraw format first
if you plan to edit it later.
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5.2 Working with Shapes

This topic explains how to perform the following operations:

Add a shape
Select, move, resize and rotate a shape
Multi selection and anchor shapes
Format shape's geometry
Add text to a shape or to the page
Format shape's text

Add a shape
Adding a shape in MyDraw is very easy - simply drag and drop any shape you like to add to your diagram from the
library browser to the drawing area of MyDraw as shown in the following image:

 

Select, move, resize and rotate a shape
To select a shape either click it or click and hold somewhere outside of it and then drag to
trigger the rectangular selection tool and select it. When the shape is selected a set of trackers
will appear around it as shown in the picture to the left.

To move a shape simply select it and drag it across the drawing area until you reach the
desired location.

To resize a shape, drag one of its corner trackers.

To rotate a shape use the circular tracker above the shape. You can also use the buttons in the
Rotate ribbon group of the Action tab from the ribbon.
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Multi selection and anchor shapes
When two or more shapes are selected MyDraw it becomes ambiguous on which shape some commands should
work, for example the align lefts command. To visualize which shape will be used for such commands, MyDraw
introduces two types of anchor shapes:

Alignment anchor - the shape that will be used by alignment commands. The trackers of the alignment
anchor are filled in black.
Format anchor - the shape that will be used by formatting commands. The trackers of the format anchor
are filled in white.

If a shape in multi selection is both alignment and a format anchor, then its trackers are filled in white, i.e. the
coloring of the format anchor takes precedence.

The following image shows how a selection with a different alignment and format anchor looks:

 

In this case the red line is the format anchor and the orange rectangle is the alignment anchor.

Format shape's geometry
To change the appearance of a shape use the split buttons in the Geometry Format ribbon group of the Home
tab. They will let you change the fill, stroke and shadow of a shape, as well as its corner rounding. If the selected
shape is a 1D shape (i.e. a connector) you can also change its start and end arrowheads.

To pick the geometry formatting of the selected shape or the format anchor shape in case of multiple selected
shapes, click the copy geometry formatting button (the rightmost pipette on the image below). Then select one or
more shapes and click the apply geometry formatting button (the rightmost brush on the image below).

 

Add text to a shape or to the page
To add text to a shape, activate the Pointer tool (the one that looks like an arrow) and double click the shape or
directly start typing. An in-place rich text editor for entering/modifying the text of the shape will open. You can use
the buttons in the Font and Paragraph ribbon groups to format and style the text of the shape. Note that in text
edit mode the text formatting ribbon commands act on the text selected in the rich text editor, but if you have simply
selected the shape and you have not entered in text edit mode, the text formatting ribbon commands modify the
formatting of the whole text of the shape.

When you have finished entering text press Escape from the clipboard or click outside of the shape to apply the text
change. If you want to cancel the text change and revert to the previous text of the shape press Shift + Escape from
the keyboard.

If you want to simply add some text to the page, then activate the Text tool (the one that looks like the letter "T"),
click and hold somewhere in the page and drag to create a text area. Then double click this text area and enter your
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text.

Format shape's text
If you want to format the whole text of a shape at once you can simply select the shape and use the controls in the
Font and Paragraph ribbon groups.

To format only parts of the shape's text, you should double click the shape in order to enter in in-place edit mode.
You should then select the text you want to style and use the controls from the ribbon to apply the desired
formatting to the selected text. You can then select another piece of the text and format it differently and so on.

You can use the copy (the pipette) and apply (the brush) text formatting buttons to copy the text formatting of a
shape and then apply it to one or more shapes in the same way you do for shape geometry.
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Before splitting:

5.3 Working with Connectors

Connect two shapes
To connect two 2D shapes you can use the Line or the Connector tool. You can find these tools in the Home tab
of the Ribbon. To activate any of them simply select the desired one. Once you’ve selected the connector type you
would like to use click on a port of the shape you want the connector to start from, then drag the mouse cursor to
a port of the shape you want the connector to end at.

When the mouse is over a port or the contour of a shape, it will get highlighted in red, this indicates that you can
start/end the connector there. The following image shows the result of using the Line tool to connect a rectangle
and an ellipse.

Connector splitting
This feature of NOV Diagram is observed when you move an existing or drop a new 2D shape over a 1D shape
geometry or end-points. The result of the operation is visually highlighted, so that the user knows whether
connector splitting or automatic connection to end-points will occur.

The following images illustrate the 1D Shape splitting:

After splitting:
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As can be seen from the Before and After images, the connector splitting operation adds a new 1D shape, that is a
cloning of the original 1D shape, with its text removed. The Original 1D Shape begin point is connected to the
dropped 2D shape.

The New 1D Shape end-point is by default connected to where the Original 1D Shape end-point was connected,
while its begin point is connected to the dropped 2D shape. To the user the operation looks like as if the original
1D shape has been split in two, hence this operation is called 1D shape splitting.
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Before automatic connection:

For 1D Shape splitting to occur the following conditions must be met:

1. The moved 2D shape CanSplit property needs to be set to true (which is the default)
2. The target 1D shape for splitting needs to have its Splittable property set to true.
3. Both the begin and end point of the 1D shape need to be outside the moved 2D shape bounds.

The CanSplit and Splittable properties can be modified from the shape properties – layout tab.
1D Shape splitting can be globally disabled by the Page – Interaction – Enable 1D Shape Splitting setting. By
default 1D Shape splitting is enabled.

Automatic connection to 1D Shape end-points
The following images illustrate the automatic connection to 1D Shape end-points:

After automatic connection:

As can be seen from the Before and After images, the automatic connection to 1D Shape end-points, has
automatically glued the begin point of the connector to the dropped 2D shape.

For automatic connection to 1D Shape end-points to occur the following conditions must be met:

MyDraw User Guide 29

©2018 Nevron Software. All Rights Reserved.



1. The moved 2D shape must be over one of the end points
2. The respective property in the Page – Interaction (i.e. Enable Connect Begin Points or Enable Connect End

Points must be set to true).
3. The target 1D shape needs to have its Splittable property set to true.

The automatic connection to 1D Shape end-points feature can be globally disabled by the Page – Interaction –
Auto Connect To Begin Points and Auto Connect To End Points settings.
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5.4 Working with Groups

In MyDraw groups are a special kind of shapes that can aggregate other shapes. For example the following is a group
that aggregates 3 shapes - a square, a circle and a triangle:

Groups support drill down selection, which means that you can select a shape within the group by first clicking on
the group to select the group and then clicking on the particular shape within the group to select it.

Group shapes together
To group two or more shapes together, you should select them and then click on the Group button from the
Action ribbon tab or press Ctrl+Shift+G from the keyboard. You can group not only shapes but other groups as
well. When a set of shapes are grouped together they will act as one shape, which means that you will be able to
easily rotate and/or resize all of them at once.

Ungroup a group of shapes
If you want to ungroup a group of shapes, click the group to select it and then click the Ungroup button from the
Action ribbon tab or press Ctrl+Shift+U from the keyboard.
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5.5 Working with Pages

Each MyDraw drawing can have one or more pages. You can easily add, remove and rename pages using the Page
Navigator. You can also use the page navigator to switch to a different page.

The sections below describe how to perform some common tasks on the current page.

Change page size and margins
To change the size of the current page, right click somewhere in it and from the context menu that appears, select
Page Properties... The page properties dialog will open. In it, take a look at the "Size" group box in the
"General" tab page and use the "Page Size" and "Page Orientation" combo boxes to set the size and the orientation
of the current page, respectively. The "General" tab page also lets you change the page margins.

Change page background and border 
To modify the appearance of the page, right click somewhere in it and from the context menu that appears, select
Page Properties... In the page properties dialog, select the "Appearance" tab and use the property editors in it
to modify the background, the border and the border thickness of the page.

Change page drawing scale
MyDraw uses a special measurement unit for all display related measures, which is the DIP (device independent
pixel that is 1/96 of an inch). By default the drawing scale is configured so 1 DIP equals 1 DIP (identity scale).

Some drawings, however, require to display either too small or too large scenes, which are impossible to visualize
without a drawing scale. In order to visualize them in a comfortable for you manner you can use the drawing scale
options.

The drawing scale is a user defined ratio between the logical unit and the display unit. For example, 1 meter = 1
mm is a commonly used Metric drawing scale. This means that 1 mm of your drawing represents 1 meter of the
real world space.

You can change the page drawing scale from the "General" tab of the page properties dialog, or you can simply
right click one of the drawing view rulers and select Change Drawing Scale from the context menu. Then in
the dialog that appears you can either enter the drawing scale manually from the measure up-down buttons or
click the Load Drawing Scale button to select one of the predefined drawing scales. Changing the drawing
scale will also change the measurement units of the ruler and the measurements of the currently selected diagram
item, which are shown in the status bar.

MyDraw User Guide 32

©2018 Nevron Software. All Rights Reserved.



 

5.6 Page Settings

To edit the settings of a page, right click it in the page navigator and select Page Properties. Alternatively, you can
right click somewhere in the page and select Page Properties from the context menu. As most property editors in
MyDraw, the page property editor is organized in tabs.

Size and Scale

MyDraw’s default page size is A4 portrait. The first two settings in the page property editor are the Drawing Scale
and Size. Depending on your needs you can modify the drawing scale or the size of the page.

Padding

Page padding is the spacing applied to the page when you size it to its content by right-clicking somewhere in the
page and selecting Size to Content.

Appearance
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To change the background color and border of the page of your diagram, go to the Appearance tab. To edit the
main color, select Background and choose the type of fill you’d like to use. You will find plenty of opportunities
including Color Fill, Stock, Linear, Radial, or Advanced Gradient Fill, Hatch or Image Fill. Each of those fill types
can be additionally modified to achieve the result you’re looking for.

To edit the border of your page, click the Border button and choose the type, color, and rounding of the border.
Don’t forget to also specify border thickness. With MyDraw you can choose to have a border on all sides of your
drawing area or on specific sides only.

Page Items

The tree view on the left side of the dialog shows the page hierarchy. Of special interest is the Items collection. It
contains all items that are placed in the page, for example shapes, groups, guide lines, etc. You can see the items by
expanding the Items collection and you can click any of the items to inspect and modify its properties.
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5.7 Inserting Images

The Insert tab page of MyDraw's ribbon lets you easily insert images.

To insert an image click the Image button of the Insert tab. A file dialog for selecting an image file will open.
MyDraw currently supports the following image formats:

Bitmap
GIF, including animated GIFs
JPEG
PNG
Nevron Raster Image (NRI)

Another way to insert images in your drawing is to fill a shape with an image. To do so, right click a shape, choose
Format Geometry from the context menu and from the submenu select Geometry Fill. The fill editor dialog will
open. In that dialog select Image Fill for fill type as shown on the following screenshot:

Click the Browse for image button to select an image to fill the shape with. If the image is an animated GIF, you
can check the Enable Frame Animation check box to insert it as an animated image.

Using the Texture Mapping button you can specify how the selected image should fill the shape - centered,
stretched, aligned to a specific side or corner or tiled.

The Enter image URL button lets you load an image from the Web.

All images inserted in MyDraw are embedded in your drawings, which means that they do not depend on the
file they were loaded from. This makes MyDraw drawings fully portable as you do not need to distribute any
additional files with them.
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5.8 Keyboard Shortcuts

MyDraw comes with extensive support for keyboard navigation and keyboard shortcuts for executing commonly
used diagram commands. The sections bellow describe the supported keyboard shortcuts divided in different
sections based on their action.

Note that most keyboard shortcuts for Windows use the Ctrl modifier key, while the equivalent ones for Mac
use the Command modifier key instead.

File Commands
Ctrl / Command + N - creates new drawing
Ctrl / Command + O - shows a dialog for selecting a drawing and opens it
Ctrl / Command + S - saves the current drawing to file
Ctrl / Command + P - prints the current drawing

Edit Commands
Ctrl / Command + X - cuts the selection
Ctrl / Command + C - copies the selection
Ctrl / Command + V - pastes the contents of the clipboard
Delete - deletes the selected shapes
Ctrl / Command + A - selects all shapes
Escape - deselects the selected shapes

Arrange and Transform Commands
Arrow Keys - move selected shapes
Ctrl / Command + H - flip horizontal
Ctrl / Command + J - flip vertical
Ctrl / Command + L - rotate left
Ctrl / Command + R - rotate right

View Commands
Ctrl / Command + [+] - zoom in, you can also use Ctrl / Command + Mouse Wheel
Ctrl / Command + [-] - zoom out, you can also use Ctrl / Command + Mouse Wheel
Ctrl / Command + 0 - zoom to 100%
Ctrl / Command + G - show/hide grid
Ctrl / Command + B - show/hide page breaks
Ctrl / Command + R - show/hide rulers
Ctrl / Command + L - show/hide guidelines
Ctrl / Command + Alt + P - show/hide ports

Tools Commands
The shortcuts below activate one of the drawing tools:

Ctrl / Command + 1 - activates the pointer tool
Ctrl / Command + 2 - activates the draw rectangle tool
Ctrl / Command + 3 - activates the draw ellipse tool
Ctrl / Command + 4 - activates the draw line tool
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Ctrl / Command + 5 - activates the draw cubic bezier tool
Ctrl / Command + 6 - activates the draw arc tool
Ctrl / Command + 7 - activates the draw elliptical arc tool
Ctrl / Command + 8 - activates the draw connector tool
Ctrl / Command + 9 - activates the create text tool
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5.9 Application Options

MyDraw lets you configure various aspects of its appearance and behavior. To access the application options open
the File menu and click the Options button. The application options dialog will open:

MyDraw's application settings are organized in 3 tab pages:

Application Settings
The application settings lets you configure the following:           

UI Theme - specifies the UI theme to use.
Language - specifies MyDraw's display language.
Contextual Help Mode - specifies the contextual help mode used in property editors. Can be one of
the following:

Collapsed - contextual help is not shown.
Focused Element - contextual help for the focused element is shown. This is the default
value
Hovered Element - contextual help for the element the mouse is over is shown.

Developer Mode - if checked MyDraw will run in developer more showing you more settings and
option to set expressions to the properties shown in most dialogs.

Behavior Settings
The General tab lets you configure the following:

Auto Save Interval - defines the time interval for auto-saving the currently opened document. By
default set to 1 minute, which means that MyDraw will save any unsaved changes to your document
every minute and offer you to recover your document in case of an unexpected shut down or crash. To
change the auto-save interval simply select the desired item from the drop down list. If you want to
disable the auto-save feature (not recommended), select "Not Defined".                           
Email Send Settings - lets you configure the email send settings MyDraw should use when sending e-
mail messages result of mail merge operation.
Automatically Check for Updates - specifies whether MyDraw should automatically check for
updates.
Warn When Saving to Non Native Format - if checked MyDraw will show a warning message that
saving to a document format other than the native MyDraw document formats (NDX and NDB) may
lead to loss of information and formatting.
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Documents Settings
The Documents tab lets you configure the Author and Company name that will be set to each new drawing you
create with MyDraw.
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6 File Formats

6.1 File Formats Overview

MyDraw can save and load drawings in many popular file formats. The following table illustrates the file formats
currently supported by MyDraw and whether they can be used to load drawings, to save drawings or both. The file
formats are ordered alphabetically.

File
Format

Load Save Notes

AutoCAD
Drawing
Interchange
(DXF)

✘ ✔ Exports only the active page of the drawing.

Enhanced
Metafile (EMF
and EMF+)

✔ ✔ Exports only the active page of the drawing.

ESRI Shapefile
(SHP)

✔ ✘

Genealogical
Data
Communication
(GEDCOM)

✔ ✔ Creates an empty file if no family tree shapes are present in the diagram. For
more information check out the Family Tree Diagrams topic.

MyDraw Binary
Drawing (NDB)

✔ ✔ Native MyDraw format. Preserves all formatting and information.

MyDraw XML
Drawing (NDX)

✔ ✔ Native MyDraw format. Preserves all formatting and information.

MyDraw XML
Drawing
Template
(NDTX)

✔ ✔ Native MyDraw format. Preserves all formatting and information.

Portable
Document
Format (PDF)

✘ ✔ Exports only the active page of the drawing.

Raster Images
(BMP, PNG,
JPG, GIF,
TIFF)

✘ ✔ Diagrams cannot be loaded from raster images, but raster images can be
inserted in a diagram by opening the Insert ribbon tab and clicking the
Image button or by configuring the fill style of a geometry to be of type
image fill. Save exports only the active page of the drawing.

Scalable Vector
Graphics (SVG)

✘ ✔ Exports only the active page of the drawing.

Visio 2003-
2010 Drawing
(VSD)

✔ ✘

Visio 2003-
2010 XML
Drawing (VDX)

✔ ✔

Visio Drawing
(VSDX)

✔ ✔

Web Page
(HTML)

✘ ✔ Exports the whole diagram to a single HTML page. If the diagram has
multiple pages, tab navigation is added to the resulting HTML page.
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6.2 AutoCAD Drawing Interchange

MyDraw lets you easily export the active page of any drawing to AutoCAD Drawing Interchange format (DXF). You
can do so in two ways:

Vector Image Export
You can export the active page to AutoCAD Drawing Interchange format (DXF) via the Vector Image Export
dialog. To open it, click File -> Export ->Vector Image. The following dialog will open:

Click the Save Image button and select "AutoCAD Drawing Interchange" for file type. For more information
about the Vector Image Export dialog, check out the Image Export documentation topic.

Direct export
To directly save the active page of the currently opened dialog to AutoCAD Drawing Interchange format (DXF),
click File -> Export -> AutoCAD Drawing Interchange . In the save dialog that opens select file name and
click Save.

6.3 ESRI Shapefile

MyDraw provides support for importing of geographical map data from the popular ESRI shapefile format (".shp").
To import a map in MyDraw, click File -> Import -> Map. In the open file dialog that opens, select the shapefile
to import and click Open.

If the shapefile you want to open has an accompanying data file (i.e. a file with the same name, but with a different
extension - ".dbf"), the following dialog will open:
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This dialog lets you configure how the data from the DBF file should be used when importing the map in MyDraw.

The "Name and Text" group box lets you select the columns that should provide the names and the texts of the
imported shapes, as well at in what zoom range the shapes and their text should be visible.

The "Fill" group box lets you select a column, whose values should be used for filling. The filling is defined by the
selected number of colors, begin and end color. MyDraw will automatically create color shades starting from the
selected begin color and ending at the end color. This lets you easily color a map by a data column defined in the
data file. For example, you can color the countries in a world map based on their population. The countries with
small population - white, the ones with more population - light green, those with large population - green and the
countries with most population - dark green.
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6.4 Genealogical Data Communication

MyDraw comes with full support for importing and exporting family tree diagrams to the popular Genealogical Data
Communication (GEDCOM) format. GEDCOM is the standard for exchanging genealogical data (like family trees)
between different genealogical software. It is commonly used for creating family tree diagrams.

GEDCOM Import
To import a GEDCOM file in MyDraw:

1. Click the File menu
2. Click Import
3. Click Family Tree
4. Select the GEDCOM file you want to open and click the Open button

GEDCOM Export
To export a GEDCOM file in MyDraw:

1. Click the File menu
2. Click Exoprt
3. Click Family Tree
4. Select the file you want to save to and click the Save button

Note that when exporting a diagram to GEDCOM format only the information contained in family tree
shapes will be exported. You will loose all other shapes and all formating and positioning. If you want to
preserve the diagram with all of its shapes and formatting then please also save it in one of the native
MyDraw formats - NDX or NDB.
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6.5 Image Export

Export a Drawing to Raster Image
MyDraw supports exporting of drawing to a set of popular raster image formats like bitmap (BMP), PNG, JPEG
and TIFF. To export a drawing to a raster image, click File -> Export -> Raster Image... The following dialog
will open:

In this dialog you can specify whether the whole page or only a part of it should be exported as well as the
resolution of the generated image in dots per inch. Note that the part of the active page that is going to be
exported to image will be highlighted, so that you can easily see what's going to be exported and what's not. When
ready, click the Save Image button to save the image to a file or use the Copy To Clipboard button to copy it
to system's clipboard, so that you can paste it easily in other programs for further processing.

Export a Drawing to Vector Image
MyDraw can export a drawing to a vector image. The following vector image formats are currently supported:

Enhanced Metafile (EMF)
Scalable Vector Graphics (SVG)
AutoCAD Drawing Interchange (DXF)

To export the active page of a drawing to a vector image, click File -> Export -> Vector Image... A dialog
similar to the one for exporting to raster images (it is shown above) will open:
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In this dialog you can specify whether the whole page or only a part of it should be exported as well as the
resolution of the generated image in dots per inch. When ready, click the Save Image button to save the image
to a file. If you click the Copy To Clipboard button, the source code of the resulting SVG will be copied to the
clipboard.
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6.6 PDF

MyDraw makes it easy to export any drawing to PDF. To do so click File -> Export -> PDF. The following dialog
will open:

The PDF export dialog lets you configure the page size and page margins and shows a preview of the export. You can
also specify the print layout that determines the zoom mode of the diagram. If the paging mode is set to "Fit To
Pages", you can specify on how many pages the diagram should be fitted. For example if you want the diagram to be
fitted on 1 page, set page columns and page rows to 1. If you want the diagram to be fitted on 6 pages, set the page
columns to 3 and page rows to 2 and so on. When ready, click the Export to PDF button to export the diagram to a
PDF file.
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6.7 Web Page

MyDraw makes it easy to export any drawing to an HTML Web Page. To do so, click File -> Export -> Web Page.

If the drawing document contains multiple pages, MyDraw will automatically embeds tab navigation in the resulting
HTML web page and each tab page in the HTML document will show a page from your original drawing. Pages are
exported in Scalable Vector Graphics (SVG) format and are directly embedded in the resulting web page. This makes
it very easy to disribute or share, because you only have to copy/send a single HTML file.
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6.8 Visio Drawing

MyDraw provides support for both importing and exporting drawing to the most widely used diagramming
document format - Visio Drawing (VSDX) format. Import of drawings in the older Visio 2003-2010 drawing format
(VSD) is also supported.

Visio Drawing Import
To import a Visio Drawing in MyDraw:

1. Click the File menu
2. Click Import
3. Click Visio Drawing
4. Select the Visio drawing you want to open and click the Open button

MyDraw will then import the selected Visio Drawing.

If a given Visio Drawing does not open properly in MyDraw, please send it to us at support@mydraw.com. This
will help us analyze it and fix any issues with it for the next version of MyDraw.

Visio Drawing Export
To export a MyDraw drawing to a Visio Drawing:

1. Click the File menu
2. Click Export
3. Click Visio Drawing
4. Enter the file name of the Visio Drawing you want to save to and click the Save button

MyDraw will then export the currently opened drawing as Visio Drawing.

If a given drawing does not export properly to Visio Drawing, please save it as a Nevron XML Drawing and send it
to us at support@mydraw.com. This will help us analyze it and fix any issues with it for the next version of
MyDraw.

Importing and exporting of drawings in the older Visio format "Visio 2003-2010 Drawing (VSD)" under Mac
requires an active Internet connection. Under Windows there isn't such requirement.
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7 Special Diagram Types

7.1 Family Tree Diagrams

MyDraw lets you create family diagram with ease. You can either start with one of the included family tree diagram
templates or create a new blank drawing and drop a family tree person shape from the family tree shapes library.

Family Tree Shapes and Events
MyDraw comes with two special shapes that you can use to create family tree diagrams:

Person shape - rectangular shape that consists of 3 parts: photo (or gender based icon if photo is not
specified), name and dates.
Family shape - circular shape that is connected to the spouses and their children and contains the year
of the spouses marriage and the year of the divorce if they are divorced. When you place and hold the
mouse pointer over a family shape, a tooltip with the exact date and place of the marriage and the divorce
(if any) will be shown.

Family tree events are entities that include a date and a place. They are used in family tree shapes to describe events,
for example birth and death for a person shape and marriage and divorce for a family shape.

Editing Shapes and Events
To edit a person or a family shape double click it and a dialog for editing its data will open. For a person shape you
can edit the person's names, gender and birth and death events and for a family shape you can edit its marriage and
divorce events.

By default events are not set and are labeled as Automatic in the dialog. To create a new event click the
Automatic button next to the event, select Family Tree Event for type and set the date and place of the event. If
you want to delete an event, click it and select Automatic or None for event type.

Adding Shapes
To add a spouse to a person shape, right click it and select the Add Spouse menu option. A spouse with be added
next to the selected person shape and a family shape will be placed below the spouses and connected to each of
them. You can then click the family shape to add children to the family.

In case you need to build your tree in the other direction, too (i.e. from children to parents) you can right click a
person shape and select the Add Parents menu option from the context menu.

Arranging Family Tree Diagrams
Family tree diagrams are automatically arranged when you add a person shape through the context menu options,
but you can also layout them by executing the Family Graph Layout from the Layout Shapes dialog (it can be
launched from the Arrange ribbon tab). In this way you can configure the different layout options, including the
layout direction (e.g. "left to right", "top to bottom", etc.).

The following image shows a part of the family tree diagram of the US President Abraham Lincoln, created with
MyDraw:
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GEDCOM Import and Export
MyDraw comes with full support for importing and exporting family tree diagrams to the popular Genealogical Data
Communication (GEDCOM) format. For more information check out the GEDCOM Import and Export topic.
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8 Advanced Tasks

8.1 Editing Shapes

Shapes dropped to the drawing view from the library browser by default contain one or more ports, so you can easily
attach connectors to them. If you create a shape using the MyDraw's drawing tools or you simply want to add more
ports to your shape, you should right click the shape and select Shape Properties... The following dialog will
open:

The tree view at the left side of the dialog shows the shape children and the controls at the right side lets you edit the
properties of the item currently selected in the tree view.

Info panel
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The info panel at the bottom of the dialog shows information about the currently edited (focused) property. For
example at the screenshot above it shows information about the "Resize in Group" property of the shape. When
the property info panel is not large enough to show the description of the property, it displays an arrowhead
pointing upwards as shown on the screenshot. Click it to expand the info panel and see the whole description for
the currently edited property.

To switch the contextual help mode of the application and show information not for the currently edited property
but for the property the mouse cursor is over, click the question mark button of the info panel. Click it again to
switch back to focused element contextual help mode.

If don't need contextual help in property editors then click the Close (the 'X') of the info panel to close it. You can
later enable the info panel again from the "General" tab of the program options (File -> Options).

Add and remove ports
If the shape does not have any ports, the ports collection may not be present, too and you will have to create it. To
do so, select the shape in the tree view and click the Add button (the green plus) in the toolbar placed below the
tree view. In the dialog that open select Ports (Port Collection) for child type and a ports collection will be
added for the shape. Then select the ports collection in the tree view and use the Add button to add one or more
ports to it.

When you add a port, the easiest way to configure its location is to select the "Relative" check box to make its
position relative to the shape bounds and then set the X and Y fields in the Location group box to values from 0
to 1, where (0, 0) denotes the top left corner of the shape's bounding box and (1, 1) denotes its bottom right
corner. For example, to create a port at the center of the right side of the shapes bounding box, you should set X
to 1 and Y to 0.5.

To remove a port, select it in the tree view and click the Delete button (the red "X") from the toolbar or press the
Delete key from the keyboard.
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8.2 Custom Shapes

MyDraw comes with a large library of predefined shapes, but if none of them is suitable for your latest diagram, don't
worry, because it's easy to create a custom shape that suits your needs. MyDraw provides several methods for
creating custom shapes:

Composing shapes
Shape composition is the process of combining the geometry of two or more shapes into one. To compose a
complex shape, create and position two or more shapes, select them either by Crtl+Click all of them or by
rectangular selection and then use one of the buttons in the Compose ribbon group of the Action tab page. The
image below demonstrates the result of different shape composition operations on a square and 4 triangles.

Drawing shapes
MyDraw also lets you draw shapes using lines, cubic beziers, arcs or freehand drawing (Nurbs tool). To draw a
custom shape, select one of these draw tools and start creating primitives (lines, curves, arcs, etc.) or create a
freehand drawing using the Nurbs tool. Each time you place the mouse cursor over the start or the end of a
primitive MyDraw will show a tooltip to remind you that you can extend the current geometry from this point. If a
primitive you are drawing closes a geometry at given point a tooltip "Close Geometry" will show to inform you that
at this point the geometry will be closed and a 2D shape will be produced.

You can use the "Edit Geometry" tool (the pencil) to modify the control points of the geometry primitives in order
to change the outline of the shape.
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8.3 Automatic Layouts

MyDraw comes with many automatic layouts that can help you arrange the shapes and connectors of your drawing
automatically in order to get esthetically pleasing results and more compact diagrams.

Layout types
MyDraw provides three main types of automatic layouts:

Box layouts - arrange only the 2D shapes of a diagram without taking into account the connectors.
Usefull when you want to order a bunch of not connected shapes in a tabular manner for example.
Graph layouts - arrange both the 2D shapes and the 1D shapes (connectors) of a diagram. Useful for
wide range of diagrams. Handles well and produces nice drawing of all kinds of connected diagrams.
Tree layouts - arrange both the 2D shapes and the 1D shapes (connectors) of a diagram. Can be regarded
as a special case of the graph layouts optimized for tree diagrams, i.e. diagrams in which each shape has
only one parent, except for the root shape, which does not have a parent shape.

The main type of the layout is indicated by its icon in the "Layout Type" combo box as shown in the image in the
next section.

Apply a layout
To apply an automatic layout to the selected shapes or to all shapes in the active page of your drawing click the
Layout button from the Arrange ribbon group of the Home tab. The following dialog will open:
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You can choose the layout you want to apply from the "Layout Type" combo box. When you select a layout a preview
will open to the right, so that you can get an idea how the layout will arrange your shapes. You can change the
settings of the layout from the controls that appear in the "General" tab page. All setting changes will immediately
reflect in the preview so you can easily see their effect on the layout.
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8.4 Drawing Templates

MyDraw comes with a large number of drawing templates, which you can use to quickly create nice diagrams. The
predefined templates are displayed in the "New Drawing" dialog, which opens when you start MyDraw or when you
click the New menu item from the MyDraw's application (File) menu.

Load a predefined template
To load one of the predefined template select it in the "New Drawing" dialog. At the root level of the dialog you
can also select the options "Blank Drawing", to create a new blank drawing and "New from Existing...", to create a
new drawing from an existing one. For more information about this dialog, check out the New Drawing Dialog
topic.

Custom templates
If you want to create a custom MyDrawing template, you should do the following:

1. Create a drawing as usual.
2. If you want, you can use the Predefined Libraries button of the library browser to close some of the

predefined shape libraries and leave only the ones related to your template opened. To do this, click the
Uncheck All button placed below the list of shape libraries, check the ones you want to use in your
drawing and then click OK.

3. Finally click the Save As... menu item from the MyDraw's application (File) menu and save the drawing
as "Nevron XML Drawing Template (*.ndtx)".

Thus your drawing template will be created and at any time you will be able to use the "New from Existing..."
option of the New Drawing Dialog to create a new drawing based on your custom template.
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8.5 Inserting Barcodes

The Insert tab page of MyDraw's ribbon lets you easily insert 1D and 2D barcodes.

Insert a 1D barcode
To insert a 1D (a.k.a. linear) barcode, click the 1D Barcode button of the Insert tab. The following dialog will
open:

In this dialog you can configure the scale and the size mode of the barcode, its background and text fill, its
symbology and text. Note that some symbologies have strict requirement on the text of the barcode, for example
an EAN13 barcode can only have 13 digits (12 digits + 1 check digit).

If you enter "0123456789012" in the dialog above, the following 1D barcode will be created:

Insert a 2D barcode
To insert a 2D (a.k.a. matrix) barcode, click the 2D Barcode button of the Insert tab. A dialog similar to the one
for 1D barcode will open. It will let you configure the scale and size mode of the barcode, its background and text
fill, its symbology and text. MyDraw currently supports the following 2D barcode symbologies:

QR code

Data Matrix
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PDF 417
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8.6 Bookmarks

When working with large drawings you may need to visit some parts of the drawing much more frequently than
others. In these cases you can take advantage of the MyDraw's bookmark feature. Bookmarks store a location and a
zoom factor and can be used to quickly move the viewport to a given location and zoom in or out the diagram.

Creating and navigating through bookmarks
To create a bookmark open the View tab of the ribbon and click the Add button from the Bookmarks ribbon
group:

After you click the Add button, enter a name for the new bookmark and click OK. MyDraw will then store the
current position in the drawing and the current zoom factor and create a bookmark with the given name. To
navigate through the bookmarks for the active page select a bookmark from the combo box or use the Previous
Bookmark and the Next Bookmark buttons. MyDraw will then start an animation and move to the selected
bookmark.

Note that bookmarks are stored on a per page basis. The ribbon shows the bookmarks for the active page.

Editing bookmarks
To edit individual bookmarks or the whole bookmarks collection of the active page, click the Edit button. The
following dialog will open:

In this dialog you can use the buttons from the toolbar below the list box on the left to add, remove or reorder the
bookmarks. If you select a bookmark from the list box, you will see its properties on the right and you can change
them if you want.

The Settings tab lets you change the transition duration for moving to the selected bookmark in milliseconds
(ms). It is by default set to 2000 ms, which is equal to 2 seconds.
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Finally click OK to apply the changes or Cancel to cancel them.
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8.7 Presentations

MyDraw lets you easily make presentations by switching to presentation mode. MyDraw presentation lets you show
each page and bookmark of your drawing with animated transitions between them.

To start a presentation on the current drawing click the View Presentation button in the status bar:

 

Alternatively, you can start a presentation by opening the View ribbon tab and then clicking the View
Presentation button. Either way, the presentation window will open and show your drawing in full screen.

At the bottom of the presentation window you will see the following widgets:

Timeline - shows the timeline of the presentation. All pages and bookmarks of your drawing are shown
as points on this timeline. The timeline is filled from its beginning to the currently shown point to indicate
the progress of the presentation. You can click any of the points or navigate using the following keyboard
keys:

Spacebar - navigates to the next point on the timeline.
Left arrow - navigates to the previous point on the timeline.
Right arrow - navigates to the next point on the timeline.
Escape - closes the presentation window.

Page Navigator - switches between the pages of your drawing. Visible only if your drawing has more
than one page.
Bookmark Navigator - navigates through the bookmarks in the current page. Visible only if the current
page has any bookmarks. For more information about bookmarks check out the Bookmarks topic.
Zoom Slider - zooms in or out the current page.
Close button - closes the presentation view and returns to the MyDraw application window. You can also
press the Escape key from the keyboard to close the presentation view.
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8.8 Mail Merge

MyDraw makes it easy to perform mail merge in order to create many documents out of one template document.
You can either save the result of the mail merge to disk as different files or you can send the files by e-mail to
different recipients. The mail merge commands of MyDraw are placed in the Mailings ribbon tab:

Configuring Mail Merge
You should start by selecting a mail merge source, for example an Excel file. To do this, open the Mailings
ribbon tab and click the Select Recipients button. In the wizard that opens follow the steps to select and
configure a mail merge data source.

After you have selected a mail merge data source you can start inserting mail merge fields into the texts of the
shapes. Using the Preview Mail Merge button you can see the results of the mail merge for the current record.
To see the mail merge result for a different record, simply use the mail merge record navigator that is placed
below the Preview Mail Merge button.

Merge and Save
The Merge & Save ribbon button executes the mail merge operation, creates a set of resulting documents and
saves them to disk in a file format of your choice. When you click this button a save file dialog opens and you can
select the template file name to save to, for example "MailMerge.pdf". Then all generated documents will be saved
in the folder of this file with a suffix showing the one-based record index of the resulting document -
"MailMerge_1.pdf", "MailMerge_2.pdf", etc.

Merge and Send
The Merge & Send ribbon button executes the mail merge operation, creates a set of resulting documents and
sends them as attached files to e-mail messages to a set of recipients. When you click this button, a dialog for
configuring e-mail send options opens:
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Note that the mandatory fields are marked with an asterisk symbol. When you enter your e-mail sending options,
select the mail merge field that contains the e-mail addresses of the recipients and click the OK button. MyDraw
will then start generating and sending the e-mail messages displaying a progress dialog while they are being sent.
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8.9 Importing Flowcharts from Excel

Importing flowchart diagram allows you to build a flowchart diagram based on table data loaded from Excel file.

Each row of that table represents a single flowchart shape.

To be able to load data successfully, the Excel table must have the follwoing columns:

Process Step ID - An unique integer value which identifies the shape.

Process Step Description - A string which will be shown as a text in the shape.

Next Step ID - The ID value of the next shape in the sequence. If there is a branching each ID must be separated by
comma. This field is not mandatory.

Connector label - The text that will be displayed on the connector that connect current shape with the next one. If
there is a branching each text must be separated by comma.

Shape Type - String which represents the shape type. The names of the most used shapes are shown in the table
below. However you can put the name of all flowcharting shapes which are present in Flowcharting Shapes library.

 

Shape name Shape

"Start" / "Stop"

"Process"

"Subprocess"

"Document"

"Decision"

 To import flowchart diagram from Excel file you need to select File -> Import -> Flowchart. In the displayed
dialog the user should set the location of the excel file, how the diagram should be laid out and the name of the sheet
where the table resides.
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